5 Replies Latest reply on Feb 6, 2003 12:25 PM by Sacha Labourey

    Clustered EJBs keep looking for DefaultPartition

    Andrew May Newbie

      I'm trying to use clustering for the first time, and I decided to make things hard for myself by not using the default partition name (this is because I know in future I will need to know how to deploy seperate partitions and I wanted to learn how to do that from the start).

      I've got an EJB jar containing a number of Entity beans and a couple of Stateless Session beans. I've added the following config to all the beans in jboss.xml:

      <cluster-config>
      <partion-name>LinuxPartition</partion-name>
      </cluster-config>

      I've set the name of the partition to Linux partition in cluster-service.xml, and the partitional starts up OK. In JNDIView I can see HAPartition/LinuxPartition.

      However, when I deploy these EJBs I get:
      javax.naming.NameNotFoundException: DefaultPartition not bound.

      Any ideas?

        • 1. Re: Clustered EJBs keep looking for DefaultPartition
          Sacha Labourey Master

          Are you sure your partition isn't bound under (HAPartition/LinuxPartition) or something like this? Can you check with the JNDI viewer?

          Cheers,


          sacha

          • 2. Re: Clustered EJBs keep looking for DefaultPartition
            Andrew May Newbie

            In JNDIView I can see:

            +- HAPartition (class: org.jnp.interfaces.NamingContext)
            | +- LinuxPartition (class: org.jboss.ha.framework.server.HAPartitionImpl)

            which is what I would expect.

            The problem is that something is trying to lookup HAPartition/DefaultPartition when I deploy my EJBs, despite them all specifying that they are clusted in the LinuxPartition.

            When I up the logging level I see this:

            2002-11-13 16:14:07,459 DEBUG [org.jboss.ejb.plugins.local.BaseLocalContainerInvoker] acs/core/Acs cannot be Bound, doesn't have local and local home interfaces2002-11-13 16:14:07,460 WARN [org.jboss.system.ServiceController] Problem starting service jboss.j2ee:jndiName=acs/core/Acs,service=EJB
            javax.naming.NameNotFoundException: DefaultPartition not bound

            My Acs bean is the only one in the Jar with remote interfaces instead of Local interfaces - it provides the interface to the entities, but I'm not sure whether the DEBUG message is significant (after all it's not a warning).

            Here's the snippet from jboss.xml:


            <ejb-name>acs/core/Acs</ejb-name>
            <jndi-name>acs/core/Acs</jndi-name>
            true
            <cluster-config>
            <partion-name>LinuxPartition</partion-name>
            </cluster-config>


            I'm tempted to resort to the DefaultPartition to see if I can get these beans deployed.

            • 3. Re: Clustered EJBs keep looking for DefaultPartition
              bongos Newbie

              I got this problem too. In my cluster-service.xml I tried to setup the HASessionStateService as below:



              jboss:service=LMPartition
              /HAPartition/LMService
              ListManagerPartition


              But when I started jboss, jboss complains that:

              2003-02-05 16:37:31,491 INFO [org.jboss.ha.hasessionstate.server.HASessionStateService] Creating
              2003-02-05 16:37:31,512 ERROR [org.jboss.ha.hasessionstate.server.HASessionStateService] Initialization failed
              javax.naming.NameNotFoundException: DefaultPartition not bound


              What's wrong? Can someone help us?

              Thanks,

              • 4. Re: Clustered EJBs keep looking for DefaultPartition
                Allen Walker Newbie

                I also had this problem on a self compiled jboss32b2.

                • 5. Re: Clustered EJBs keep looking for DefaultPartition
                  Sacha Labourey Master

                  Please provide the full stacktrace.

                  Cheers,


                  mahna mahna