2 Replies Latest reply on Nov 15, 2002 7:39 AM by Sanjay

    clustering problem

    Sanjay Newbie

      Hello,
      I am facing problem while setting up cluster.
      Actually its not working for failover. I mande necessary changes in "cluster-service.xml" and also created "farm-service.xml".
      I am using jboss3.0 with tomcat.
      When I started jboss on two different machines its shows me " Number of members in partition as 2" but when I shutdown one server(where actually my application is running) failover does not take place and application crashes saying "page not found". Do I need to give any other settings.

      Following are my xml files

      Cluster-service.xml
      --------------------

      <?xml version="1.0" encoding="UTF-8"?>

      <!-- ===================================================================== -->
      <!-- -->
      <!-- Sample Clustering Service Configuration -->
      <!-- -->
      <!-- ===================================================================== -->






      <!-- ==================================================================== -->
      <!-- Cluster Partition: defines cluster -->
      <!-- ==================================================================== -->

      <!--
      -->

      <!-- ************** Added by Sanjay ************** -->


      MyPartition
      true


      <!-- ************** Added by Sanjay ************** -->

      <!-- ==================================================================== -->
      <!-- HA Session State Service for SFSB -->
      <!-- ==================================================================== -->


      jboss:service=MyPartition
      MyPartition


      <!-- ==================================================================== -->
      <!-- HA JNDI -->
      <!-- ==================================================================== -->


      jboss:service=MyPartition
      MyPartition






      ====================================================

      farm-service.xml
      -----------------

      <?xml version="1.0" encoding="UTF-8"?>
      <!-- ===================================================================== -->
      <!-- -->
      <!-- Sample Farming Service Configuration -->
      <!-- -->


      <!-- ==================================================================== -->
      <!-- Cluster Partition: defines cluster -->
      <!-- ==================================================================== -->
      <!-- Farm Deploy Directory and Scanner Name must not be set here because this
      are the default values but when you want to change them do it here.
      -->

      jboss:service=MyPartition
      MyPartition
      .farm
      jboss.deployment:type=DeploymentScanner,flavor=URL



      =====================================

      Please let me know as it is urgent. At present I am running j2ee application with stateless session beans.

      Awaiting reply.

      Regds
      ~Sanajy

        • 1. Re: clustering problem
          Sacha Labourey Master

          Can you show us the stack trace you have? If that is the JVM that crashes, then you should change of JVM: there is nothing we can do for you at the bytecode level :)

          • 2. Re: clustering problem
            Sanjay Newbie

            hello,
            Thanks for the reply.
            Is the configuration that I made in
            "cluster-service.xml" and "farm-service.xml" correct.
            Do I need to copy all my deployable resource to all the nodes in a cluster(partition) or are these resources shared by everyone(as they would be deployed on single system).

            Can you elaborate more on all\farm directory. I mean how to work with this directory. what is meant by farm components. am I supposed to copy all my deployable components to this directory. If so then will that not have duplicacy with all\deploy dir components(as all deployables are in this dir).

            Awaiting your reply

            Regds,
            Sanjay