4 Replies Latest reply on Feb 18, 2003 3:06 AM by Sacha Labourey

    second partition

    Stefan Faist Newbie

      Hi,
      when I start a node in a own partition I get following error:
      ========== begin server.log =======================
      ...

      Cause: Incomplete Deployment listing:
      Packages waiting for a deployer:

      Incompletely deployed packages:

      MBeans waiting for classes:

      MBeans waiting for other MBeans:
      [ObjectName: jboss:service=ClusteredHttpSession
      state: CONFIGURED
      I Depend On: jboss.j2ee:service=EJB,jndiName=clustering/HTTPSession

      Depends On Me: , ObjectName: jboss.j2ee:service=EJB,jndiName=clustering/HTTPSession
      state: NOTYETINSTALLED
      I Depend On: jboss:service=DefaultPartition
      jboss:service=invoker,type=jrmp

      Depends On Me: jboss:service=ClusteredHttpSession

      ...

      ========== end server.log ===========================


      This is my cluster-service.xml:

      ========== begin cluster-service.xml ================
      <?xml version="1.0" encoding="UTF-8"?>

      <!-- ===================================================================== -->
      <!-- -->
      <!-- Sample Clustering Service Configuration -->
      <!-- -->
      <!-- ===================================================================== -->






      <!-- ==================================================================== -->
      <!-- Cluster Partition: defines cluster -->
      <!-- ==================================================================== -->


      MySpecialNewPartition
      True


      <!-- ==================================================================== -->
      <!-- HA Session State Service for SFSB -->
      <!-- ==================================================================== -->


      jboss:service=MySpecialNewPartition
      MySpecialNewPartition


      <!-- ==================================================================== -->
      <!-- HA JNDI -->
      <!-- ==================================================================== -->


      61100
      MySpecialNewPartition
      jboss:service=MySpecialNewPartition







      ========== end cluster-service.xml ==================
      Can someone help me?
      The error line 'I Depend On: jboss:service=DefaultPartition'
      say something about the DefaultPartition. Is there a other xml-file where I must define the Partition perhaps in the jbossha-httpsession.sar?

      Regards
      Stefan