4 Replies Latest reply on Dec 20, 2002 9:52 AM by Sacha Labourey

    Clustering with 3.0.3/4 fails to retrieve stub from server

    Dirk Sturzebecher Newbie

      Hi,

      have been trying to get clustering to work but always get a exception, as below. Does anybody have it working. Saw other peoples posting with similar problems, but did see no solutions. Did they giveup?

      javax.naming.CommunicationException: Failed to retrieve stub from server 192.168.0.3:1100 [Root exception is java.io.StreamCorruptedException: unexpected block data]
      at de.ovsag.profiler.proxies.ProxyStateless.(ProxyStateless.java:26)

      Have simplified the setup as far as possible:

      - only one server (linux)
      - JBoss 3.0.3 (tried 3.0.4 as well)
      - JDK 1.4.1 (tried 1.3.1 as well)
      - one stateless and one stateful session bean

      Remarks:
      - Startup and deployment shows no problems
      - JBoss starts in standard ALL "mode"
      - jboss.xml is true
      - JNDI properties are as given in doc
      - application works in DEFAULT "mode" (with modified jboss.xml and JNDI)
      - both beans are accessable via a servlet

      What is the problem? Routing? How to verify that nothing is blocked? I got a route and everything which even looks like a firewall is disabled (as far as I can tell)...