3 Replies Latest reply on Feb 13, 2003 11:23 AM by Gabriel Buades

    JBOSS hot deployment

    Paulo Lima Newbie

      Hi All,

      I am trying to get Jboss hot deployment working and so far I have not been very successfull.

      I Have Jboss running on 3 different Linux servers in the same subnet. I run the distributed Jboss 3.0.6 (jetty) using -c all and the default cluster-service.xml, the farm-service.xml was changed to include option 1) on the webeserver dependency.

      So far I have verified that the multicast is working OK. Also JBOSS seems to be listening on the multicast addresses 228.1.2.3 and 230.0.0.4 (I used netstat -gn).

      The farm directory does not get created.

      Any hints on what I should try next?

      Thanks!

      On the server.log file I get the following error message:
      ++++
      2003-02-04 13:34:59,232 INFO [org.jboss.deployment.MainDeployer] Starting deplo
      yment of package: file:/usr/local/jboss-3.0.6/server/all/deploy/farm-service.xml
      2003-02-04 13:34:59,361 INFO [org.jboss.deployment.MainDeployer] Deployed packa
      ge: file:/usr/local/jboss-3.0.6/server/all/deploy/farm-service.xml
      2003-02-04 13:34:59,365 ERROR [org.jboss.deployment.scanner.URLDeploymentScanner
      ] MBeanException: Exception in MBean operation 'checkIncompleteDeployments()'
      Cause: Incomplete Deployment listing:
      Packages waiting for a deployer:

      Incompletely deployed packages:

      MBeans waiting for classes:

      MBeans waiting for other MBeans:
      [ObjectName: jboss:service=FarmMember,partition=DefaultPartition
      state: CONFIGURED
      I Depend On: jboss:service=DefaultPartition
      jboss.ejb:service=EJBDeployer
      jboss.web:service=JBossWeb
      jboss.system:service=MainDeployer

      Depends On Me: ]
      +++++

        • 1. Re: JBOSS hot deployment
          Sacha Labourey Master

          are you sure that the HAPartition is correctly started (wihtout any error) and that you haven't changed its JMX ObjectName?


          mahna

          • 2. Re: JBOSS hot deployment
            bongos Newbie

            I got the same problem. My JBOSS is running on 2 Win2k servers and in the same subnet.

            I am using:

            jboss-3.0.6_tomcat-4.1.18
            JDK 1.3.1
            Win2k

            When I view JNDIView. I see HAPartition and my cluster partition name is under HAPartition. Does that means HAPartition is running?

            • 3. Re: JBOSS hot deployment
              Gabriel Buades Newbie

              It seems as if JBossWeb has change its name to WebServer.

              In Jboss 3.0.4, Jetty was declared at jbossweb.sar/META-INF/jboss-service.xml using
              <mbean code="org.jboss.jetty.JettyService" name="jboss.web:service=JBossWeb">
              ...


              In JBoss 3.0.6, Jetty is declared as

              <mbean code="org.jboss.jetty.JettyService" name="jboss.web:service=WebServer">
              ...


              so, you must change your farm-service.xml dependencies to:

              jboss.web:service=WebServer

              I hope it to be useful.