9 Replies Latest reply on Jul 7, 2003 12:39 PM by Kevin

    Farming doesn't work according to docs

    Kevin Newbie

      HI all,

      I am trying the farming setup according to the article I found from July of 2002. I am a bit confused though on what I am seeing. We depend on Oracle, so we have an oracle-ds.xml in the /all/deploy. We also have a login-config.xml, not entirely sure what that does. We also have our own email-service.xml I suppose to use our email servers, not entirely sure what that one is for as well.

      I followed the doc, set up the clustering, and finally got my one redhat9 box and one windowsXP box to see each other and cluster. In /all/deploy there is the farm-service.xml file. I am assuming it works? It indicates a ./farm dir. I created this dir, and from what I am reading, if I put my ejb-jar files in the /all/farm dir on one server, it will deploy it and automatically pass it on to other servers in the node.

      When I put our ejb-jar in the /all/deploy folder, it seems to deploy, but doesn't get farmed. When I move it to the /farm dir, I get a ton of exceptions, indicating our beans can't find the Oracle DS. I put the oracle-jdbc.jar in the /all/lib dir, so it should be found there I assume?

      The good thing is, when I put our .jar in the /farm dir, it DOES get copied/deployed to the linux server (yeah). However, on both the windows and linux servers, I am seeing tons of exceptions and ultimately the application isn't deployed.

      I am going to take a wild guess that all the /lib files, and the various config files in the /deploy dir do NOT get copied over? If not, then that would mean all that stuff must be on all servers already, and the only thing that has a chance of being deployed to the cluster is the .jar/.ear/.war files? Or does anything I put in the /farm dir get copied over?

      Thanks for any help.

        • 1. Re: Farming doesn't work according to docs
          Darran Lofthouse Master

          Yes, the only items that will be copied to the other nodes in the cluster are the items found in the farm folder. It is assumed that all of the other required items will have been installed on all nodes.

          I did try putting my JDBC driver in lib on all nodes and the *-service.xml file in the farm dir as well as my application but I had problems with the deployment order on the different nodes.

          I have never tried putting other items in the farm folder so I do not know if you could deploy your JDBC driver in that way.

          The solution that I found was to deploy absolutely everything in a single ear (Including my JDBC driver) and put the ear into farm, everything deploys fine across the cluster.

          I do however have some problems with redeployments (I can not get them to work) but that looks more like a classloader issue.

          • 2. Re: Farming doesn't work according to docs
            Sacha Labourey Master

            Darran,

            you are right, only what is in /farm is... farmed! :)

            For the deployment issues, can you try a recent Branch_3_2? with these, the content of farm is deployed AFTER anything in deploy.

            Cheers,


            sacha

            • 3. Re: Farming doesn't work according to docs
              Kevin Newbie

              Sorry, I wrote all my forum posts before we finally got things working. Now that we have it working, the two issues we have are why farming doesn't redeploy on the farmed machines, and why our client app is not using round robin when connecting to the servers. It uses one and then sticks to that server, unless it goes down, then it seems to find the other server after some time.

              Sorry Sacha, regarding other posts. I did read the doco, we bought it. I understood what it meant but I suppose as I was digging deeper, finding the ha-client jar got me a little confused. Why is that there if it is not needed? Or, what is it for? Does it provide something I could use on the client?

              I got the 3.2.2 branch from sourceforge CVS, the RC1 build. Is that the latest. I saw your post a while back regarding grabbing the latest branch becuase you fixed something. At that time there was only 3.2.1 available, so when I saw 3.2.2RC1, I assumed you had it fixed in that branch? If not, where in the CVS repository do I get the latest build? I run Eclipse and have the CVS repository view opened and can't seem to figure out what of the many folders there I should be grabbing. Do I need to build it?

              Thanks.

              • 4. Re: Farming doesn't work according to docs
                Sacha Labourey Master

                I will test the farming stuff. As for ha-client.jar it is needed for fat java clients that want to use clustering. That is a requirements.

                sacha

                • 5. Re: Farming doesn't work according to docs
                  Kevin Newbie

                  I figured that. But how? Do I just put it in my apps classpath, and suddenly it works? Or do I have to make specific use of it in some proprietary fashion to use jboss clustering? If so, I need to know how so that I can abstract that just in case we decide to deploy on another server. Is there any information regarding the client HA library that instructs on how to use it?

                  • 6. Re: Farming doesn't work according to docs
                    jackpot Newbie

                    I also need help in setting upt cluster. Appreciate if you can help me with those docs that you have and some additional know-how.

                    Thank You
                    Jackpot

                    • 7. Re: Farming doesn't work according to docs
                      Darran Lofthouse Master

                      You will need to pay for the clustering documentation, there should be a link to the right of the page saying 'BUY Jboss DOCO'

                      • 8. Re: Farming doesn't work according to docs
                        Sacha Labourey Master

                        for the original farming issue, I just tried with 3.2.x (last 3.2.x) and it works, try again. If it doesn't work for you with such release:
                        - put jboss logging in debug mode on both nodes
                        - try again
                        - zip BOTH log files and either attach them here or send them to sacha@jboss.org

                        Cheers,


                        sacha

                        • 9. Re: Farming doesn't work according to docs
                          Kevin Newbie

                          Sacha,

                          Took you a while to respond. ;) I figured out the problem, wasn't nothing to do with farming. However, in a later post I noticed that while hot-deploy works fine, hot-redeploy does not, although I did see that hot-undeploy works.