2 Replies Latest reply on Jan 12, 2004 2:37 PM by pyramid6

    Need help with clustering

    pyramid6 Newbie

      I am using jboss 3.2.3(200401020004) with the all configuration. I am using linux and I have multicast working; I tested it with some java programs. The two servers are running everything the same, same kernel, same config, same jboss, and same jvm. Neither are dhcp and they are both on the same subnet. The only thing I can find wrong is:

      java.net.SocketException: bad argument for IP_MULTICAST_IF: address not bound to any interface

      I can remove the offending line in cluster-service.xml and that prevents that error, but the clustering still does not work.

      Is there anyway I can trouble shoot this? Does clustering really work out of the box?

      Thanks,

      Anthony

      PS The line I have trouble with is:
      ${jboss.bind.address}

        • 1. Re: Need help with clustering
          pyramid6 Newbie

          Sorry here is the code again.

          <attribute name="BindAddress">${jboss.bind.address}</attribute>

          I have also read the docs on clustering, and I have tried changing ${jboss.bind.address} to 127.0.0.1 and to the nonloopback ip addresses.

          The only thing I can think of to do is to download another version and try it.

          Thanks,

          Anthony

          • 2. Re: Need help with clustering
            pyramid6 Newbie

            Further updates:

            Ok, I was able to get rid of the problem with the adrress binding, but it will still not cluster. Atleast I think it won't.

            How can I trouble shoot this? I will try anything. Does anyone know of anyway to see what is going on? I have looked through the log files and they are not helpful. I have read the documentation and it is not helpful. I have not touched any configuration files. I am not sure what to do else to try, any ideas?

            Thanks,

            Anthony