1 Reply Latest reply on Feb 27, 2004 1:12 PM by Xavier

    Commit option A in a cluster

    Xavier Newbie

      Hi all,

      After a brief break in my development, I see I got no answer for my last post, and I'm still locked trying to make entities cache work on a clustered environment.

      I'm using:
      - Jboss3.2.3 with server option 'all'
      - Container configuration shown at the end of the message is defined in standardjboss.xml
      - All CMP entities are using the configuration mentioned above (<configuration-name>Clustered CMP 2.x EntityBean with cache invalidation</configuration-name>), and with tags 'clustered' and 'cache-invalidation' both set to true.

      And entities cache is not kept between transactions. Actually in the jmx-console cache size for every CMP is always 0, when I'm only reading data from the EJBs, so cache invalidation shouldn't have invalidated any data.
      Can anybody tell me what I'm missing?


      This is the 'Clustered CMP 2.x EntityBean with cache invalidation' container configuration I'm using for all my CMPs. It's just a copy of the default configuration 'Clustered CMP 2.x EntityBean' that comes with jboss 'all' server option modifying:
      . Instance cache: org.jboss.ejb.plugins.InvalidableEntityInstanceCache
      . Commit option: A
      and adding cache invalidation interceptor:
      . org.jboss.cache.invalidation.triggers.EntityBeanCacheBatchInvalidatorInterceptor

       <container-configuration>
       <container-name>Clustered CMP 2.x EntityBean with cache invalidation</container-name>
       <call-logging>false</call-logging>
       <invoker-proxy-binding-name>clustered-entity-rmi-invoker</invoker-proxy-binding-name>
       <sync-on-commit-only>false</sync-on-commit-only>
       <insert-after-ejb-post-create>false</insert-after-ejb-post-create>
       <container-interceptors>
       <interceptor>org.jboss.ejb.plugins.ProxyFactoryFinderInterceptor</interceptor>
       <interceptor>org.jboss.ejb.plugins.CleanShutdownInterceptor</interceptor>
       <interceptor>org.jboss.ejb.plugins.LogInterceptor</interceptor>
       <interceptor>org.jboss.ejb.plugins.SecurityInterceptor</interceptor>
       <interceptor>org.jboss.ejb.plugins.TxInterceptorCMT</interceptor>
       <interceptor metricsEnabled="true">org.jboss.ejb.plugins.MetricsInterceptor</interceptor>
       <interceptor>org.jboss.ejb.plugins.EntityCreationInterceptor</interceptor>
       <interceptor>org.jboss.ejb.plugins.EntityLockInterceptor</interceptor>
       <interceptor>org.jboss.ejb.plugins.EntityInstanceInterceptor</interceptor>
       <interceptor>org.jboss.ejb.plugins.EntityReentranceInterceptor</interceptor>
       <interceptor>org.jboss.resource.connectionmanager.CachedConnectionInterceptor</interceptor>
       <interceptor>org.jboss.ejb.plugins.EntitySynchronizationInterceptor</interceptor>
       <interceptor>org.jboss.cache.invalidation.triggers.EntityBeanCacheBatchInvalidatorInterceptor</interceptor>
       <interceptor>org.jboss.ejb.plugins.cmp.jdbc.JDBCRelationInterceptor</interceptor>
       </container-interceptors>
       <instance-pool>org.jboss.ejb.plugins.EntityInstancePool</instance-pool>
       <instance-cache>org.jboss.ejb.plugins.InvalidableEntityInstanceCache</instance-cache>
       <persistence-manager>org.jboss.ejb.plugins.cmp.jdbc.JDBCStoreManager</persistence-manager>
       <locking-policy>org.jboss.ejb.plugins.lock.QueuedPessimisticEJBLock</locking-policy>
       <container-cache-conf>
       <cache-policy>org.jboss.ejb.plugins.LRUEnterpriseContextCachePolicy</cache-policy>
       <cache-policy-conf>
       <min-capacity>50</min-capacity>
       <max-capacity>1000000</max-capacity>
       <overager-period>300</overager-period>
       <max-bean-age>600</max-bean-age>
       <resizer-period>400</resizer-period>
       <max-cache-miss-period>60</max-cache-miss-period>
       <min-cache-miss-period>1</min-cache-miss-period>
       <cache-load-factor>0.75</cache-load-factor>
       </cache-policy-conf>
       </container-cache-conf>
       <container-pool-conf>
       <MaximumSize>100</MaximumSize>
       </container-pool-conf>
       <commit-option>A</commit-option>
       </container-configuration>
      


      Thanks

      Xavier