8 Replies Latest reply on Nov 26, 2004 3:27 PM by Bela Ban

    non multicating(TCP), server dont see each other.

    raj_kumar Newbie

      hi all ,
      i'm running my JBOSS in cluster without multicasting that means i had configured my JBOSS in TCP ... and i'm running 2 JBOSS on different machine .... but the problem is that my JBOSS starts without any error oe exception but the problem is that they both didnt identify each other ... my cluster-service .xml file is :---


      <!-- UDP: if you have a multihomed machine,
      set the bind_addr attribute to the appropriate NIC IP address -->
      <!-- UDP: On Windows machines, because of the media sense feature
      being broken with multicast (even after disabling media sense)
      set the loopback attribute to true -->
      <TCP start_port="12800"/>
      <TCPPING initial_hosts="192.9.200.152[12800],192.9.200.150[12800]" port_range="5" timeout="3000" num_initial_members="3" up_thread="true" down_thread="true"/>
      <MERGE2 min_interval="5000" max_interval="10000"/>
      <FD shun="true" up_thread="true" down_thread="true" timeout="2500" max_tries="5"/>
      <VERIFY_SUSPECT timeout="3000" num_msgs="3" up_thread="true" down_thread="true"/>
      <pbcast.STABLE desired_avg_gossip="20000" up_thread="true" down_thread="true"/>
      <pbcast.NAKACK gc_lag="50" retransmit_timeout="300,600,1200,2400,4800" up_thread="true" down_thread="true"/>
      <UNICAST timeout="5000" window_size="100" min_threshold="10" down_thread="true"/>
      <FRAG frag_size="8192" down_thread="true" up_thread="true"/>
      <pbcast.GMS join_timeout="5000" join_retry_timeout="2000" shun="true" print_local_addr="true"/>
      <pbcast.STATE_TRANSFER up_thread="true" down_thread="true"/>



      according to documents in "initail hosts" i had given the IP of two machines and in machineA has also the same file and in machineB also have the same cluster-service.xml.

      pls tell me any solution ....

      bela...?

      Regards
      Raj........

        • 1. non multicating(TCP), server dont see each other.
          raj_kumar Newbie

          one more thing ..........
          i'm using jboss3.2.2 on windows 2000

          Regards
          Raj.....

          • 2. Re: non multicating(TCP), server dont see each other.
            Michael Daleiden Newbie

            I think you're TCP config is off a bit. Here's what I have (also running JBoss 3.2.2 on Win2K -- IP addresses masked for security reasons):

            <TCP start_port="7800" bind_addr="143.61.XXX.XXX"/>
             <TCPPING initial_hosts="143.61.XXX.YYY[7800]" port_range="1" timeout="3000"
             num_initial_members="1" up_thread="true" down_thread="true"/>
             <FD shun="true" up_thread="true" down_thread="true"
             timeout="2500" max_tries="5" />
             <VERIFY_SUSPECT timeout="1500" up_thread="false" down_thread="false" />
             <pbcast.NAKACK gc_lag="100" retransmit_timeout="3000" up_thread="true" down_thread="true" />
             <pbcast.STABLE desired_avg_gossip="20000" up_thread="false" down_thread="false" />
             <pbcast.GMS join_timeout="5000" join_retry_timeout="2000" shun="false" print_local_addr="false" down_thread="true" up_thread="true" />
             <pbcast.STATE_TRANSFER up_thread="true" down_thread="true"/>

            Note that my config does not have a UNICAST tag and that pbcast.NAKACK comes before pbcast.STABLE. Also, if your machine is multi-homed (has more than one IP address), you will need to specify the bind_addr attribute on the TCP tag to indicate which IP address the cluster is bound to. In addition, you're initial_hosts should only point to the other servers in the cluster and not include the current server's IP address, num_initial_hosts should be set to the actual number of servers specified in initial_hosts, and unless you really need to have the cluster scan multiple ports on each host, set the port_range to 1.

            • 3. Re: non multicating(TCP), server dont see each other.
              Bela Ban Master

              Yes, for multihomed systems you need the bind_addr parameter.

              Also, by enabling the logs (in log4j.xml) you might have seen what the problem was.

              Bela

              • 4. Re: non multicating(TCP), server dont see each other.
                raj_kumar Newbie

                sorry for replying u late ....
                thanks alot ...its working ....
                Raj.........

                • 5. Re: non multicating(TCP), server dont see each other.
                  Afshan Zabihi Newbie

                  Hi All,
                  I am using jboss 3.2.3 and jgroup is 2.2.0 under winXP. I try to use TCP but it does not work.
                  the cluster-service.xml :

                  <TCP start_port="11800" bind_addr="Y.X.Z.7" loopback="true" />
                   <TCPPING initial_hosts="Y.X.Z.63[11800]"
                   port_range="1"
                   timeout="3000"
                   num_initial_members="1"
                   up_thread="true"
                   down_thread="true" />
                  
                   <MERGE2 min_interval="5000" max_interval="10000" />
                   <FD shun="true" up_thread="true" down_thread="true"
                   timeout="2500" max_tries="5" />
                   <VERIFY_SUSPECT timeout="3000" num_msgs="3"
                   up_thread="true" down_thread="true" />
                   <pbcast.NAKACK gc_lag="50" retransmit_timeout="300,600,1200,2400,4800"
                   up_thread="true" down_thread="true" />
                   <pbcast.STABLE desired_avg_gossip="20000"
                   up_thread="true" down_thread="true" />
                   <UNICAST timeout="5000" window_size="100" min_threshold="10"
                   down_thread="true" />
                   <FRAG frag_size="8192"
                   down_thread="true" up_thread="true" />
                   <pbcast.GMS join_timeout="5000" join_retry_timeout="2000"
                   shun="true" print_local_addr="true" />





                  • 6. Re: non multicating(TCP), server dont see each other.
                    Bela Ban Master

                    1. Read the docs on jgroups.org.
                    2. Make sure *all* hosts that are running are listed in the XML, e.g.:

                    <TCP start_port="11800" bind_addr="Y.X.Z.7" loopback="true" />
                     <TCPPING initial_hosts="Y.X.Z.63[11800],Y.X.Z.7[11800]"
                     port_range="3"
                     timeout="3000"
                     num_initial_members="2"
                     up_thread="true"
                     down_thread="true" />
                    


                    • 7. Re: non multicating(TCP), server dont see each other.
                      Afshan Zabihi Newbie

                      Hi bela,
                      I read in some other documents that you should not include the host itself in config file. e.g. i we have two hosts x.y.z.1 and x.y.z.2 then in x.y.z.1 host's configuration x.y.z.1 should not be part of "initial_hosts" paramater.


                      • 8. Re: non multicating(TCP), server dont see each other.
                        Bela Ban Master

                        No, that's fine. Make sure all hosts can ping each other.

                        Bela