3 Replies Latest reply on Jan 27, 2005 2:47 PM by Sean Boltman

    Could not load the org.jboss.ejb.plugins.ServiceEndpointInte

    Shu Sato Newbie

      Hello,

      (I posted this to JBoss Developer's forum and re-post here again.)

      I get the following warning mesasge every time when stateless session
      beans are deployed onto clustered JBoss AS 4.0.0.

      16:59:42,034 INFO [EjbModule] Deploying BorrowRecordSearch
      16:59:42,058 WARN [EjbModule] Could not load the org.jboss.ejb.plugins.ServiceEndpointInterceptor interceptor


      My standardjboss.xml in conf dir is the same as one in 'all' server
      config and contains settings of the ServiceEndpointInterinterceptor like this:

      <container-configuration>
      <container-name>Clustered Stateless SessionBean</container-name>
      ....
      org.jboss.ejb.plugins.ServiceEndpointIntercep
      tor
      ....
      org.jboss.ejb.plugins.ServiceEndpointInterceptor</
      interceptor>
      ....

      but I couldn't find such a class in jar files of JBoss 4.0.0 binaries.

      My questions are
      (i) The warning message is caused by wrong
      configurations(in standardjboss.xml) and negligible?

      (ii) If (i) is true, is removing the interceptor configuration
      from standardjboss.xml no problem to make stateless session beans work
      in clustered environments?

      (iii) If (i) is incorrect, any ideas to remove the warnings???

      -shu