7 Replies Latest reply on Mar 10, 2006 4:57 PM by Ted Yu

    XAConnectionFactory not bound

    Christofer Dutz Newbie

      Hello Alan,

      > I'm happy to answer any questions that aren't covered
      > in the documentation. I used the default
      > configuration thats in the docs for clustered
      > stateless session beans and it worked fine. The only
      > difficulty I had was in creating the client. My
      > client code didn't need to be modified at all, but I
      > did have to figure out how to run it under a security
      > manager, which is something I've never done before.

      Thank you for this very positive feedback, I do really appreciate! ;)

      For the security manager thing, that is interesting. Have you added the jbossha-client.jar file to the classpath of your client? Do you remember for which class it was complaining if you didn't set a security manager?

      Cheers,



      Sacha

        • 1. Re: XAConnectionFactory not bound
          Scott Stark Master

          Moved to the user forum. Check out the JBossMQ wiki page.

          • 2. Re: XAConnectionFactory not bound
            Christofer Dutz Newbie

            Ok ... here once again ...
            I am using JBoss 4.0.0 and when using the all-config for seting up a cluster everything seems to work fine. As soon as the 3rd, and every node after that, I get XAConnectionFactory not bound (and "queue not bound", but I think they are very closely realted). The errors occur upon application deployment where the MDBs are normaly bound to the JMS queues.

            I had a look at the wiki before posting here and to the developer list. I have no further ideas of what could be going wrong. My colleagues and I worked on this 8 Hous yesterday, 8 hours today and mabe will try again tomorow. If we can't get the benchmark ready this weekend, we will have to write in our final report, that it is not possible to run SPECjAppServer2004 on a Jboss cluster in the timeframe our customer provisded us with.

            Have a nice weekend,
            Chris

            • 3. Re: XAConnectionFactory not bound
              Scott Stark Master

              No exceptions + No configuration == No answers.

              • 4. Re: XAConnectionFactory not bound
                Bjoern Weis Newbie

                Hi,

                I have created a test case to reproduce the warn (error).

                The scenario is the following:
                1. Take standard all configuration from jboss-4.0.0
                2. Copy jmstest.jar in the deploy directory
                3. clone the all configuration twice
                4. start first jboss
                5. start second jboss
                6. start third jboss

                After the third jboss has deployed the jmstest.jar the second jboss output the warn the XAConnectionFactory is no longer bounded. Now the JMS queues only work on the first and the third server.

                The jmstest.jar do nothing than try to bound the SendMessSes to the queue/A.

                You can download the jmstest.jar file from http://www.ehs.de/jmstest.jar.

                Thanks for helping us.

                Kind regards
                Bjoern


                PS: I am working on the same project as Chris.
                PPS:
                In the server.log the messages of the second server is:

                2004-12-19 09:53:07,227 DEBUG [org.jboss.ha.singleton.HASingletonController]
                
                partitionTopologyChanged, isElectedNewMaster=false, isMasterNode=false,
                
                viewID=-1651571363
                2004-12-19 09:53:19,788 DEBUG [org.jboss.remoting.network.NetworkRegistry] addServer
                
                - JBOSS Identity
                
                [address:cannes/130.83.166.180,instanceid:e34873f6f4c35c85x1893efex100e7648708x-7ffd1
                
                35,JMX
                
                id:130.83.166.180/1103446345885/e4350c3179b4ce87x789144x100ea87089cxX800026/1,domain:
                
                JBOSS]
                2004-12-19 09:53:22,750 INFO [org.jboss.cache.TreeCache] viewAccepted(): new
                
                members: [genua:32899, koeln:32908, cannes:32838]
                2004-12-19 09:53:23,902 DEBUG
                
                [org.jboss.ha.framework.server.DistributedReplicantManagerImpl.DefaultPartition]
                
                _add(jboss.j2ee:jndiName=SendMessSes,service=EJB, 130.83.166.180:1099
                2004-12-19 09:53:23,902 DEBUG
                
                [org.jboss.ha.framework.server.DistributedReplicantManagerImpl.DefaultPartition]
                
                notifyKeyListeners
                2004-12-19 09:53:23,902 DEBUG
                
                [org.jboss.ha.framework.server.DistributedReplicantManagerImpl.DefaultPartition]
                
                notifying 2 listeners for key change: jboss.j2ee:jndiName=SendMessSes,service=EJB
                2004-12-19 09:53:23,902 DEBUG [org.jboss.ha.framework.server.HATarget]
                
                replicantsChanged 'jboss.j2ee:jndiName=SendMessSes,service=EJB' to 3 (intra-view id:
                
                -1651571363)
                2004-12-19 09:53:23,902 DEBUG [org.jboss.proxy.ejb.ProxyFactory] Rebinding in JNDI...
                
                jboss.j2ee:jndiName=SendMessSes,service=EJB
                2004-12-19 09:53:23,902 DEBUG [org.jboss.proxy.ejb.ProxyFactory] (re-)Binding Home
                
                SendMessSes
                2004-12-19 09:53:24,093 WARN
                
                [org.jboss.ha.framework.interfaces.HAPartition.DefaultPartition]
                
                javax.naming.NameNotFoundException: XAConnectionFactory not bound
                2004-12-19 09:53:24,927 WARN
                
                [org.jboss.ha.framework.interfaces.HAPartition.DefaultPartition]
                
                javax.naming.NameNotFoundException: queue not bound
                2004-12-19 09:53:24,946 WARN
                
                [org.jboss.ha.framework.interfaces.HAPartition.DefaultPartition]
                
                javax.naming.NameNotFoundException: XAConnectionFactory not bound
                2004-12-19 09:53:25,111 WARN
                
                [org.jboss.ha.framework.interfaces.HAPartition.DefaultPartition]
                
                javax.naming.NameNotFoundException: queue not bound
                2004-12-19 09:53:29,324 DEBUG [org.jboss.ha.framework.server.FarmMemberService]
                
                farmDeployments request, parentDUMap.size=1
                



                • 5. Re: XAConnectionFactory not bound
                  Claus Kolb Newbie

                  Hi,

                  although I am using a different JBoss-Version (3.2.6) I also get this WARNING. But my application is working fine.
                  Is your application working and doing what it should? I had a problem that I solved getting a new XAConnectionFactory every time I needed one.

                  Does the failover work?

                  Regards,
                  Claus

                  • 6. Re: XAConnectionFactory not bound
                    Bjoern Weis Newbie

                    Hi,

                    no, the SPECjAppServer2004 deployment don't work. It seems that I could not use the deployment descriptors which I used in a JBoss 3.2.3 cluster environment.

                    In JBoss 3.2.3 cluster the queues was transparent to the application, so I do not need to use an other port to look up the queues.

                    Now I am changing this in the deployment descriptors (like <jndi-name>jnp://localhost:1100/queue/ReceiveQueue</jndi-name>) and hope this will work.

                    Kind regards
                    Bjoern

                    PS: Thanks Claus I got this idea from your post in http://www.jboss.org/index.html?module=bb&op=viewtopic&t=54596 ;-)

                    • 7. Re: XAConnectionFactory not bound
                      Ted Yu Newbie

                      Our app has trouble running on JBoss 4.0.3

                      2006-03-10 13:09:38,840 ERROR [org.jboss.ejb.plugins.jms.JMSContainerInvoker] Reconnect
                      failed: JMS provider failure detected:
                      javax.naming.NameNotFoundException: XAConnectionFactory
                      at org.jboss.ha.jndi.TreeHead.lookup(TreeHead.java:223)
                      at org.jboss.ha.jndi.HAJNDI.lookup(HAJNDI.java:134)
                      at sun.reflect.GeneratedMethodAccessor127.invoke(Unknown Source)
                      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl
                      .java:25)
                      at java.lang.reflect.Method.invoke(Method.java:585)
                      at org.jboss.ha.framework.interfaces.HARMIClient.invoke(HARMIClient.java:229)
                      at $Proxy440.lookup(Unknown Source)
                      at org.jnp.interfaces.NamingContext.lookup(NamingContext.java:610)

                      2006-03-10 13:09:44,648 ERROR [org.jboss.ejb.plugins.jms.JMSContainerInvoker] Reconnect
                      failed: JMS provider failure detected:
                      java.lang.NullPointerException
                      at org.jboss.metadata.MetaData.getChildrenByTagName(MetaData.java:66)
                      at org.jboss.metadata.MetaData.getOptionalChild(MetaData.java:134)
                      at org.jboss.metadata.MetaData.getOptionalChild(MetaData.java:115)
                      at org.jboss.ejb.plugins.jms.DLQHandler.importXml(DLQHandler.java:423)
                      at org.jboss.ejb.plugins.jms.JMSContainerInvoker.innerStartDelivery(JMSContaine
                      rInvoker.java:604)

                      How do I make JMS work ?