2 Replies Latest reply on Dec 25, 2004 3:22 AM by jieshengz

    Error compiling monitoring manager #0

    jieshengz Newbie

      I running jboss-3.2.6 "all" server in a Linux machine. The OS is redhat Enterprise Linux 3. In this linux machine, run the "default" server, there is no problem. However when I started the "all" server, I got this exception
      ----------------------------
      2004-12-24 18:35:26,980 INFO [org.jboss.web.WebService] Using RMI server codebase: http://develop2.redzero.com:8083/
      2004-12-24 18:35:28,059 INFO [org.jboss.naming.NamingService] Started jndi bootstrap jnpPort=1099, rmiPort=1098, backlog=50, bindAddress=/0.0.0.0, Client SocketFactory=null, Server SocketFactory=org.jboss.net.sockets.DefaultSocketFactory@ad093076
      2004-12-24 18:35:39,122 WARN [org.jboss.jmx.adaptor.snmp.agent.TrapEmitter] Error compiling monitoring manager #0
      java.net.BindException: Cannot assign requested address
      at java.net.PlainDatagramSocketImpl.bind(Native Method)
      at java.net.DatagramSocket.bind(DatagramSocket.java:368)
      at java.net.DatagramSocket.(DatagramSocket.java:210)
      (.......)
      2004-12-24 18:35:43,666 INFO [org.jboss.ha.framework.interfaces.HAPartition.DefaultPartition] Initializing
      2004-12-24 18:35:43,892 INFO [org.jgroups.protocols.UDP] unicast sockets will use interface 211.100.15.76
      2004-12-24 18:35:43,893 ERROR [org.jgroups.JChannel] exception: java.lang.Exception: exception caused by UDP.start(): java.lang.Exception: UDP.createSockets(): cannot list on any port in range 0-1
      2004-12-24 18:35:43,965 ERROR [org.jboss.ha.framework.server.ClusterPartition] Starting failed jboss:service=DefaultPartition
      ChannelException: java.lang.Exception: exception caused by UDP.start(): java.lang.Exception: UDP.createSockets(): cannot list on any port in range 0-1
      at org.jgroups.JChannel.connect(JChannel.java:328)
      at org.jboss.ha.framework.server.ClusterPartition.startService(ClusterPartition.java:257)
      at org.jboss.system.ServiceMBeanSupport.jbossInternalStart(ServiceMBeanSupport.java:271)

      -------------------------

      I can start this configured "all" server in my window machine and another linux machine without any problem. It seems to be socket binding proble. Not sure whether it is multicast related or not.

      Any help is really appreciated

      jason