0 Replies Latest reply on Feb 11, 2005 5:57 PM by V Rao G

    Cluster Problemin Jboss 4.RC2 - Linux

    V Rao G Newbie

      I am running two nodes say A and B, one each on different mechines with the partion name server1 on same network. Node A started first then Node B Started. Node B log says other cluster members are 0. Is itn't suppose to say 1? Any idea what i am doing wrong? pasted below are my logs

      Node B Logs:

      GMS: address is esdev01:32815 (additional data: 14 bytes)
      -------------------------------------------------------
      2005-02-11 14:15:04,853 DEBUG [org.jboss.ha.framework.server.ClusterPartition] Starting channel
      2005-02-11 14:15:04,854 DEBUG [org.jboss.ha.framework.interfaces.HAPartition.server1] get nodeName
      2005-02-11 14:15:04,859 DEBUG [org.jboss.ha.framework.interfaces.HAPartition.server1] Get current members
      2005-02-11 14:15:04,860 INFO [org.jboss.ha.framework.interfaces.HAPartition.server1] Number of cluster members: 1
      2005-02-11 14:15:04,860 INFO [org.jboss.ha.framework.interfaces.HAPartition.server1] Other members: 0
      2005-02-11 14:15:04,861 INFO [org.jboss.ha.framework.interfaces.HAPartition.server1] Fetching state (will wait for 30000 milliseconds):
      2005-02-11 14:15:04,920 INFO [org.jboss.ha.framework.interfaces.HAPartition.lifecycle.server1] New cluster view for partition server1 (id: 0, delta: 0) : [127.0.0.1:1099]


      -------------------------------------------------------
      GMS: address is esdev01:32818
      ------------------------------------------------------- 2005-02-11 14:15:22,152 INFO [org.jboss.cache.TreeCache] viewAccepted(): new members: [esdev01:32818]
      2005-02-11 14:15:22,153 INFO [org.jboss.cache.TreeCache] new cache is null (maybe first member in cluster)
      2005-02-11 14:15:22,154 INFO [org.jboss.cache.TreeCache] state could not be retrieved (must be first member in group)
      2005-02-11 14:15:22,277 DEBUG [org.jboss.cache.TreeCache] Started jboss.cache:service=TomcatClusteringCache
      2005-02-11 14:15:22,277 DEBUG [org.jboss.system.ServiceController] Starting dependent components for: jboss.cache:service=TomcatClusteringCache dependent components: []





      Thanks in Advance
      GV