1 Reply Latest reply on Aug 29, 2005 12:04 PM by aarpm ,pmtamp

    3 Clustered JBoss Behind a firewall

    aarpm ,pmtamp Newbie

      Hi:

      I followed the guide "UsingJBossBehindAFirewall" and I managed to get an EJB to work correctly behind a firewall (I'm using the default ports). I opened TCP ports 1098, 1099, 4444 and 8083 and everything works great when making a call like jnp://jbossone:1099. But now I have 3 JBoss clustered using the "DefaultPartition" and need to use HAJNDI, so I tried to call my EJB using "jbossone:1100,jbosstwo:1100,jbossthree:1100" and also opened port 1100 on my firewall but I get no response... I doesn't even "time out", it seems to be frozen!

      I'm using 3 JBoss in different PCs, all version 4.0.1sp1. All JBoss have the default cluster configuration and are behind the same firewall (there's no firewall between each Jboss). I added the true tag to the jboss.xml for my EJB and deployed it on all Jboss servers.
      I tried "telnet jbossone 1100" and I get this response:
      ??srjava.rmi.MarshalledObject|???c?>IhashlocBytest[BobjBytesq~xp?w?srjava.rmi.MarshalledObject|???c?>IhashlocBytest[BobjBytesq~xp?w??ur[B???T?xpB??thttp://jbossone:8083/q~q~q~q~q~q~q~uq~??s}org.jnp.interfaces.Naming,org.jboss.ha.framework.interfaces.HARMIProxyxrjava.lang.reflect.Proxy?'? ?C?Lht%Ljava/lang/reflect/InvocationHandler;xpsr-org.jboss.ha.framework.interfaces.HARMIClient???j???LfamilyClusterInfot5Lorg/jboss/ha/framework/interfaces/FamilyClusterInfo;LkeytLjava/lang/String;LloadBalancePolicyt5Lorg/jboss/ha/framework/interfaces/LoadBalancePolicy;xpwDefaultPartition/HAJNDIsrjava.util.ArrayListx????a?Isizexpwsr2org.jboss.ha.framework.server.HARMIServerImpl_Stubxrjava.rmi.server.RemoteStub?????exrjava.rmi.server.RemoteObject?a??
      a3xpw6
      UnicastRef2
      172.17.1.65?%s?????xxa6?sr,org.jboss.ha.framework.interfaces.RoundRobinx.???:xpxConnection closed by foreign host.

      So I guess it can communicate well through the firewall, but I don't know why it is "freezing" when I call an EJB using jnp://jbossone:1100. (or using a list separeted by " , ")
      Something weird is that it doesn't even give me an exception or time out...

      Am I missing some important ports or other configuration?
      JNDI works great (port 1099), it is just HAJNDI that doesn't work (port 1100)
      Thanks for your help
      Aaron