1 Reply Latest reply on Oct 25, 2005 12:00 PM by Srinivasan Sangameswara

    JMS in a cluster

    Srinivasan Sangameswara Newbie

      I have two instances (server 1 and server 2) of JBoss running on the same machine as a cluster. I have the port numbers for all the listeners on port 2 incremented by 100.

      What I see happening is this:

      When I bring up both the servers, I see server 1 acting as the JMS master. When I bring down server 1, server 2 takes over as the JMS master.

      The strange part is when I restart server 1, the bean acting as the message pump on server 1 says the ConnectionFactory (XAConnectionFactory) is not bound whereas server 2 is the master.

      autodiscovery has been enabled on JNDI to discover the ConnectionFactory using jnp.disableDiscovery=false (java.naming.factory.initial=org.jnp.interfaces.NamingContextFactory
      and java.naming.factory.url.pkgs=org.jboss.naming:org.jnp.interfaces).

      Am I missing something in the configuration.
      Please help.

        • 1. Re: JMS in a cluster
          Srinivasan Sangameswara Newbie

          I meant server 2 on line 1 for incrementing the port numbers for the listeners.

          The posting with the change is as follows:

          I have two instances (server 1 and server 2) of JBoss running on the same machine as a cluster. I have the port numbers for all the listeners on server 2 incremented by 100.

          What I see happening is this:

          When I bring up both the servers, I see server 1 acting as the JMS master. When I bring down server 1, server 2 takes over as the JMS master.

          The strange part is when I restart server 1, the bean acting as the message pump on server 1 says the ConnectionFactory (XAConnectionFactory) is not bound whereas server 2 is the master.

          autodiscovery has been enabled on JNDI to discover the ConnectionFactory using jnp.disableDiscovery=false (java.naming.factory.initial=org.jnp.interfaces.NamingContextFactory
          and java.naming.factory.url.pkgs=org.jboss.naming:org.jnp.interfaces).

          Am I missing something in the configuration.
          Please help.