3 Replies Latest reply on Feb 9, 2006 8:42 PM by Luis Mendes

    Merge Failed error on JBoss 4.0.4RC1 (version 200602071519)

    Luis Mendes Newbie

      I've just installed the new JBoss 4.0.4RC1 and it seems that JBAS-2439 http://jira.jboss.com/jira/browse/JBAS-2439 isn't solved yet.

      I started jboss instances on two separate machines waited for the initial joins then unplugged the network cable, I waited again for the member status update and then plugged the network cable and got the following message:

      ...
      22:23:51,518 INFO [DefaultPartition] New cluster view for partition DefaultPartition: 3 ([10.0.1.5:1099, 10.0.1.10:1099] delta: 1)
      22:23:51,518 INFO [DefaultPartition] Merging partitions...
      22:23:51,519 INFO [DefaultPartition] Dead members: 0
      22:23:51,519 INFO [DefaultPartition] Originating groups: [[10.0.1.5:33063 (additional data: 13 bytes)|2] [10.0.1.5:33063 (additional data: 13 bytes)], [Marsk6:33420 (additional data: 14 bytes)|2] [Marsk6:33420 (additional data: 14 bytes)]]
      22:23:51,630 ERROR [DefaultPartition] merge failed
      java.lang.ClassCastException: java.lang.ClassCastException
      at org.jboss.ha.framework.server.DistributedReplicantManagerImpl.mergeMembers(DistributedReplicantManagerImpl.java:890)
      at org.jboss.ha.framework.server.DistributedReplicantManagerImpl$MergeMembers.run(DistributedReplicantManagerImpl.java:1033)
      ...


      I've tested with the bundled Jgroups version and with Jgroups 2.2.9.1, the results were the same.
      I was hoping that this was solved in this version as it was the reason why I updated from 4.0.3SP1.

      If this problem gets confirmed, can it be expected a fix version soon?

      Thanks