12 Replies Latest reply on Apr 12, 2006 6:36 AM by Nikhil Goel

    Session is not getting replicated on JBoss-4.0.2

    Nikhil Goel Newbie

      My Clustering is working properly on 3.2.3, 3.2.5 along with the session replication.

      But there are a lot of diifferences in the folder structure in 4.0.2 from 3.2.5.
      So can anybody have any idea about how I can make the settings for session replication in 4.0.2 & 4.0.3.
      Cluster is working properly.
      Let me give you some idea what I have done.
      I have taken 2 nodes all and node2. I am using all as node1.
      I am using modJK. I did dome changes in
      1)cluster-service.xml(loopback=true)
      2)tc5-cluster-service.xml(loopback=true)
      3)deploy\jbossweb-tomcat55.sar\server.xml & jvmRoute="node2"
      4)deploy\jbossweb-tomcat55.sar\META-INF\jboss-service.xml(usejk= true)
      5)httpha-invoker.sar\META-INF\jboss-service.xml
      in some more xml's but not the major change
      Added tag in web.xml
      Application is running on both the servers but loosing its session when I shutdown 1 instance. I mean Its asking me to login again.
      Actually I m in a great need can somebody help me out.
      You can also catch me on my personal mail id is nikhil.goel@yahoo.com.

      Thanks in advance.

      Regards
      Nikhil
      09313119770

        • 1. Re: Session is not getting replicated on JBoss-4.0.2
          Brian Stansberry Master

          Are you sure your session is lost? After you log in again, does your session have proper state (i.e. some attributes set on node1 still have those values)?

          If the session does have proper state, and you are using FORM authentication, what you are seeing is due to the fact that the info needed for continued transparent FORM authentication is not replicated with the session, see:

          http://jira.jboss.com/jira/browse/JBAS-1900

          • 2. Re: Session is not getting replicated on JBoss-4.0.2
            Ian Otahal-Mechura Newbie

            Here is a good link to test your cluster configuration

            http://wiki.jboss.org/wiki/Wiki.jsp?page=TestingJBoss

            Please post back your results.

            • 3. Re: Session is not getting replicated on JBoss-4.0.2
              Nikhil Goel Newbie

              Thanks for replying.
              Yeah everything is fine.I am not using any form authentication.
              Actually I am accessing Resource Adapter through a web application.
              In the previous versions what I used to do is just changed some port settings to make the things working.
              Infact I am not getting any logs also for session replication.
              Just getting the messages for
              New Member
              Dead member etc.
              As you know I am using Apache .
              When I fire the 1st request its going on any server either on all or on node2.
              When I shutdown the server which is currently handling the request & start tring to access the application it shows me session expired. Login again.
              I was not doing specific for session replication for Jboss-3.2.5 also but the application was running fine.
              Let me elaborate it.
              For Jboss-3.2.5
              1. Copy the all folder from <JBoss_Home>\server and paste into the same directory for 2 times.
              Note: - all is the name of the folder.
              Now rename them to node2 & node3.
              2. Move to node2 folder -> open <JBoss_Home>\server\node2\deploy\http-invoker.sar\META-INF\ jboss-service.xml file.
              Do the following changes into it.

              Change 8080 everywhere in the file to 18080.

              3. Move to <JBoss_Home>\server\node2\deploy\jbossweb-tomcat41.sar\META-INF\ jboss-service.xml
              Search for
              <Engine name="MainEngine" defaultHost="localhost"
              Add jvmRoute=?node2? to the tag.
              Similarly do it into the all folder also like
              <Engine name="MainEngine" defaultHost="localhost" jvmRoute=?node1?>

              Search for
              <Connector className="org.apache.coyote.tomcat4.CoyoteConnector"
              Change the port of this from 8080 to 18080
              Similarly
              Again Search for
              <Connector className="org.apache.coyote.tomcat4.CoyoteConnector"
              Change the port from 8009 to 18009.

              4) move to <JBoss_Home>\server\node2\deploy\jms\oil2-service.xml
              Search for ServerBindPort change from 8092 to 18092

              5) move to <JBoss_Home>\server\node2\deploy\jms\oil-service.xml
              Search for ServerBindPort change from 8090 to 18090


              5) <JBoss_Home>\server\node2\deploy\jms\uil2-service.xml
              Search for ServerBindPort change from 8093 to 18093

              6) <JBoss_Home>\server\node2\deploy\cluster-service.xml
              <mbean code="org.jboss.ha.jndi.HANamingService"
              Port :- from 1100 to 11100
              Find the loopback and set it true.

              7) D:\jboss-3.2.3\server\node2\deploy\snmp-adaptor.sar\managers.xml
              Change the port from 1162 to 11162

              8) D:\jboss-3.2.3\server\node2\deploy\snmp-adaptor.sar\META-INF\jboss-service.xml

              Change the port from 1162 to 11162


              7) <JBoss_Home>\server\node2\conf\jboss-minimal.xml
              Search for
              Change the port from 1099 to 11099

              8) <JBoss_Home>\server\node2\conf\jboss-service.xml

              Change the port from 8083 to 18083


              Change the port from 1099 to 11099
              Change the RmiPort from 1098 to 11098


              Change the RMIObjectPort from 4444 to 14444


              Change the ServerBindPort from 4445 to 14445


              Can you send me the whole configuration required , from making the second instance till the deployment. Because I have tried many scenarios
              As now I have added jboss-web.xml with the following code
              <jboss-web>
              <replication-config>
              <replication-trigger>SET_AND_GET</replication-trigger>
              <replication-type>SYNC</replication-type>
              <replication-granularity>ATTRIBUTE</replication-granularity>
              </replication-config>
              </jboss-web>
              but still I am not getting the session replication.
              The behaviour is same.

              • 6. Re: Session is not getting replicated on JBoss-4.0.2
                Nikhil Goel Newbie

                yes I have added the tag into my web.xml

                Actually without this the application should not work on 3.2.3 & 3.2.5 versions also.....right.

                So my question is it is working on 3.2.3 , 3.2.5
                Clustering, faming is also working on 4.0.2 but the session replication is not getting done.

                I have gone through many sites ,done many changes but still not getting the session replication.

                That's y I am asking for the list of all the changes required for JBoss-4.0.2
                from making a separate instance till the deployment.

                Thanks for replying.
                Waiting for ur response.
                Thanks again

                • 7. Re: Session is not getting replicated on JBoss-4.0.2
                  Brian Stansberry Master

                  1) See this wiki page for getting two JBoss instances running on one machine:

                  http://wiki.jboss.org/wiki/Wiki.jsp?page=ConfiguringMultipleJBossInstancesOnOneMachine

                  All the config changes you're making are too painful and mistakes may lead to issues. If your machine has more than one IP, using the -b switch is the recommended approach.

                  2) If you are using mod_jk, edit /server/nodeX/deploy/jbossweb-tomcat50.sar/server.xml to add the jvmRoute to the Engine element and also edit /server/nodeX/deploy/jbossweb-tomcat50.sar/META-INF/jboss-service.xml to set attribute UseJK to "true".

                  3) Your web.xml and jboss-web.xml seem fine. Get rid of the replication-type element in jboss-web.xml; it's not used anymore although I don't think it does any harm.

                  4) Try it out and see if it works.

                  5) If not, edit deploy/tc5-cluster-service.xml and set loopback=true there.

                  • 8. Re: Session is not getting replicated on JBoss-4.0.2
                    Nikhil Goel Newbie

                    Hey I have checked the cluster setting with 2 sample applications

                    samplewar.war having following testsessionreplication.jsp into it for the 1st instance


                    <body bgcolor=blue>

                    <%=request.getSession().getId() %>
                    <h1>Tomcat 1</h1>



                    Similarly
                    samplewar.war having following testsessionreplication.jsp into it for the 2nd instance


                    <body bgcolor=green>

                    <%=request.getSession().getId() %>
                    <h1>Tomcat 2</h1>



                    the sessionit is giving is same I think the session is getting replicated.
                    But when I am trying the same JBoss-4.0.2 configurations with my application ,which is working fine in JBoss-3.2.3 & 3.2.5 the session is not getting replicated. So now can you tell me something what all changes required for a web application.
                    As I have added a tag in web.xml
                    introduced a new jboss-web.xml inside the web-inf folder of the application with the code

                    <?xml version="1.0" encoding="UTF-8"?>
                    <jboss-web>
                    <replication-config>
                    <replication-trigger>SET_AND_NON_PRIMITIVE_GET</replication-trigger>
                    <replication-granularity>ATTRIBUTE</replication-granularity>
                    </replication-config>
                    </jboss-web>

                    I am giving you the list of all the files in which I have made changes till now.
                    I have tried many scenarios I mean combinations of these paramaters

                    For jboss-4.0.3SP1

                    1)jboss-4.0.3SP1\server\node2\deploy-hasingleton\jms\uil2-service.xml
                    put 28093 instead of 8093 for ServerBindPort

                    2)jboss-4.0.3SP1\server\node2\conf\jboss-minimal.xml
                    put 21099 instead of 1099 for Port
                    put 21098 instead of 1098 for RmiPort

                    3)jboss-4.0.3SP1\server\node2\conf\jboss-service.xml
                    put 28083 instead of 8083 for Port
                    put 21099 instead of 1099 for Port
                    put 21098 instead of 1098 for RmiPort
                    put 24444 instead of 24444 for RMIObjectPort
                    put 24445 instead of 4445 for ServerBindPort

                    4)jboss-4.0.3SP1\server\node2\deploy\httpha-invoker.sar\META-INF\jboss-service.xml
                    changed port from 8080 to 28080 everwhere in this file.

                    5)jboss-4.0.3SP1\server\node2\deploy\jbossweb-tomcat55.sar\server.xml
                    changed
                    <Connector port="8080" to <Connector port="28080"
                    and
                    <Connector port="8009" to <Connector port="28009"
                    and
                    <Engine name="jboss.web" defaultHost="localhost"
                    to

                    I have also added jvmRoute="node1" into all folder also.

                    6)jboss-4.0.3SP1\server\node2\deploy\jbossweb-tomcat55.sar\META-INF\jboss-service.xml
                    previously I changed the usejk as true but for the application samplewar (given above), I haven't made any changes into this file.
                    I have also tested after changing the value of UseLocalCache as false.

                    7)jboss-4.0.3SP1\server\node2\deploy\jboss-ws4ee.sar\META-INF\jboss-service.xml
                    changed 8080 to 28080 for WebServicePort.

                    8)jboss-4.0.3SP1\server\node2\deploy\jms\hajndi-jms-ds.xml
                    previously changed the value from 1100 to 21100
                    but now its left as it is.

                    9)jboss-4.0.3SP1\server\node2\deploy\snmp-adaptor.sar\META-INF\jboss-service.xml
                    Changed the value from 1162 to 21162.
                    Changed the value from 1161 to 21161.

                    10)jboss-4.0.3SP1\server\node2\deploy\snmp-adaptor.sar\managers.xml
                    Changed the value from 1162 to 21162.

                    11)jboss-4.0.3SP1\server\node2\deploy\cluster-service.xml
                    changed the loopback="false" to "true"
                    changed the port 1100 to 21100
                    changed the port 1101 to 21101
                    changed the port 4447 to 24447
                    changed the port 4446 to 24446

                    I have added tag in my web.xml
                    also added jboss-web.xml into my web-inf folder with the code
                    <jboss-web>
                    <replication-config>
                    <replication-trigger>SET_AND_GET</replication-trigger>
                    <replication-granularity>ATTRIBUTE</replication-granularity>
                    </replication-config>
                    </jboss-web>

                    deploy this application into the deploy folder of the server instances.
                    But the session in not getting replicated.
                    If I shutdown the request handling server , then its giving session timeout.
                    Ask me to login again.

                    I have given the steps which I have followed for JBoss-3.2.3 & 3.2.5.
                    this application I mean ear was running fine along with session replication.
                    Just after adding tag into that.
                    I didnt added jboss-web.xml into that.

                    Can you guide me something in this regard.
                    Actually Here I am stuck,nto able to get the solution by myself.
                    So please help me ASAP.

                    So can you send me the list of all the changes which I need to do to make my application work on JBoss-4.0.2/4.0.3.

                    Thanks in advance for ur support.
                    Regards
                    Nikhil Goel
                    09313119770

                    • 9. Re: Session is not getting replicated on JBoss-4.0.2
                      Brian Stansberry Master

                      Re: config, in my last response I told you what to do re: getting two nodes running on the same server. Please don't keep posting long lists of file changes related to port changes, they are too much to read and you're not going to get a response.

                      Noticed that you were using SYNC mode before; this is now configured in the /deploy/tc5-cluster-service.xml file -- change CacheMode to REPL_SYNC. If your test is immediately switching from one server to another (i.e. not at human speed; an automated test) you could outrun async replication.

                      The other changes you need to make are included in my last response.

                      I recommend that in your jsp you actually set an attribute. The session should replicate when first created even without this, but after that it won't if you don't set or get an attribute.

                      • 10. Re: Session is not getting replicated on JBoss-4.0.2
                        Nikhil Goel Newbie

                        Hi Brian

                        I have tried REPL_SYNC also.But the session still not getting replicated.
                        Incorporated ur previous changes also. But still not working
                        Hey Brian is there any paid help for JBoss which will tell me the complete procedure for configuring a cluster on JBoss-4.0.2 & 4.0.3.
                        I am attaching my logs Just ahve a look at this


                        all node when the other node being shut down.
                        2006-04-07 16:59:53,909 INFO [org.jboss.system.server.Server] JBoss (MX MicroKernel) [4.0.2 (build: CVSTag=JBoss_4_0_2 date=200505022023)] Started in 1m:6s:66ms
                        2006-04-07 17:02:25,009 INFO [org.jboss.ha.framework.interfaces.HAPartition.lifecycle.DefaultPartition] New cluster view for partition DefaultPartition (id: 1, delta: 1) : [10.224.0.74:1099, 10.224.0.74:31099]
                        2006-04-07 17:02:25,009 DEBUG [org.jboss.ha.framework.interfaces.HAPartition.DefaultPartition] membership changed from 2 to 2
                        2006-04-07 17:02:25,009 DEBUG [org.jboss.ha.framework.interfaces.HAPartition.DefaultPartition] Begin notifyListeners, viewID: 1
                        2006-04-07 17:02:25,009 DEBUG [org.jboss.ha.framework.interfaces.HAPartition.DefaultPartition] End notifyListeners, viewID: 1
                        2006-04-07 17:02:25,009 DEBUG [org.jboss.ha.framework.interfaces.HAPartition.DefaultPartition] Begin notifyListeners, viewID: 1
                        2006-04-07 17:02:25,009 INFO [org.jboss.ha.framework.server.DistributedReplicantManagerImpl.DefaultPartition] I am (10.224.0.74:1099) received membershipChanged event:
                        2006-04-07 17:02:25,009 INFO [org.jboss.ha.framework.server.DistributedReplicantManagerImpl.DefaultPartition] Dead members: 0 ([])
                        2006-04-07 17:02:25,009 INFO [org.jboss.ha.framework.server.DistributedReplicantManagerImpl.DefaultPartition] New Members : 1 ([10.224.0.74:31099])
                        2006-04-07 17:02:25,009 INFO [org.jboss.ha.framework.server.DistributedReplicantManagerImpl.DefaultPartition] All Members : 2 ([10.224.0.74:1099, 10.224.0.74:31099])
                        2006-04-07 17:02:25,009 DEBUG [org.jboss.ha.framework.interfaces.HAPartition.DefaultPartition] End notifyListeners, viewID: 1
                        2006-04-07 17:02:25,039 DEBUG [org.jboss.ha.framework.interfaces.HAPartition.DefaultPartition] getState called.
                        2006-04-07 17:02:25,039 DEBUG [org.jboss.ha.framework.interfaces.HAPartition.DefaultPartition] getState for DistributedReplicantManager
                        2006-04-07 17:02:25,039 DEBUG [org.jboss.ha.framework.interfaces.HAPartition.DefaultPartition] getState for HASessionStateTransfer
                        2006-04-07 17:02:25,039 DEBUG [org.jboss.ha.hasessionstate.server.HASessionStateImpl./HASessionState/Default] Building and returning state of HASessionState
                        2006-04-07 17:02:25,039 DEBUG [org.jboss.ha.framework.interfaces.HAPartition.DefaultPartition] getState for HAJNDI
                        2006-04-07 17:02:25,039 DEBUG [org.jboss.ha.framework.interfaces.HAPartition.DefaultPartition] getState for DistributedState
                        2006-04-07 17:02:25,410 DEBUG [org.jboss.ha.framework.server.DistributedReplicantManagerImpl.DefaultPartition] _add(HAJNDI, 10.224.0.74:31099
                        2006-04-07 17:02:25,410 DEBUG [org.jboss.ha.framework.server.DistributedReplicantManagerImpl.DefaultPartition] _adding new HashMap
                        2006-04-07 17:02:25,410 DEBUG [org.jboss.ha.framework.server.DistributedReplicantManagerImpl.DefaultPartition] notifyKeyListeners
                        2006-04-07 17:02:25,410 DEBUG [org.jboss.ha.framework.server.DistributedReplicantManagerImpl.DefaultPartition] notifying 1 listeners for key change: HAJNDI
                        2006-04-07 17:02:25,410 DEBUG [org.jboss.ha.framework.server.HARMIServerImpl$RefreshProxiesHATarget] replicantsChanged 'HAJNDI' to 2 (intra-view id: -736827279)
                        2006-04-07 17:02:25,560 DEBUG [org.jboss.ha.framework.server.DistributedReplicantManagerImpl.DefaultPartition] _add(HAJNDI, 10.224.0.74:31099
                        2006-04-07 17:02:25,560 DEBUG [org.jboss.ha.framework.server.DistributedReplicantManagerImpl.DefaultPartition] notifyKeyListeners
                        2006-04-07 17:02:25,560 DEBUG [org.jboss.ha.framework.server.DistributedReplicantManagerImpl.DefaultPartition] notifying 1 listeners for key change: HAJNDI
                        2006-04-07 17:02:25,560 DEBUG [org.jboss.ha.framework.server.HARMIServerImpl$RefreshProxiesHATarget] replicantsChanged 'HAJNDI' to 2 (intra-view id: -736827279)
                        2006-04-07 17:02:25,580 DEBUG [org.jboss.ha.framework.server.DistributedReplicantManagerImpl.DefaultPartition] _add(DCacheBridge-DefaultJGBridge, 10.224.0.74:31099
                        2006-04-07 17:02:25,580 DEBUG [org.jboss.ha.framework.server.DistributedReplicantManagerImpl.DefaultPartition] _adding new HashMap
                        2006-04-07 17:02:25,580 DEBUG [org.jboss.ha.framework.server.DistributedReplicantManagerImpl.DefaultPartition] notifyKeyListeners
                        2006-04-07 17:02:25,580 DEBUG [org.jboss.ha.framework.server.DistributedReplicantManagerImpl.DefaultPartition] notifying 1 listeners for key change: DCacheBridge-DefaultJGBridge
                        2006-04-07 17:02:25,580 DEBUG [org.jboss.cache.invalidation.bridges.JGCacheInvalidationBridge] The list of replicant for the JG bridge has changed, computing and updating local info...
                        2006-04-07 17:02:25,580 DEBUG [org.jboss.cache.invalidation.bridges.JGCacheInvalidationBridge] ... No bridge info was associated to this node
                        2006-04-07 17:02:25,640 DEBUG [org.jboss.cache.invalidation.bridges.JGCacheInvalidationBridge] Updating list of invalidation groups that are bridged...
                        2006-04-07 17:02:25,640 DEBUG [org.jboss.cache.invalidation.bridges.JGCacheInvalidationBridge] ... nothing needs to be bridged.
                        2006-04-07 17:02:25,961 DEBUG [org.jboss.ha.framework.server.DistributedReplicantManagerImpl.DefaultPartition] _add(jboss.ha:service=HASingletonDeployer, 10.224.0.74:31099
                        2006-04-07 17:02:25,961 DEBUG [org.jboss.ha.framework.server.DistributedReplicantManagerImpl.DefaultPartition] _adding new HashMap
                        2006-04-07 17:02:25,961 DEBUG [org.jboss.ha.framework.server.DistributedReplicantManagerImpl.DefaultPartition] notifyKeyListeners
                        2006-04-07 17:02:25,961 DEBUG [org.jboss.ha.framework.server.DistributedReplicantManagerImpl.DefaultPartition] notifying 1 listeners for key change: jboss.ha:service=HASingletonDeployer
                        2006-04-07 17:02:25,961 DEBUG [org.jboss.ha.singleton.HASingletonController] partitionTopologyChanged, isElectedNewMaster=true, isMasterNode=true, viewID=-736827279
                        2006-04-07 17:02:33,632 INFO [org.jboss.cache.TreeCache] locking the tree to obtain transient state
                        2006-04-07 17:02:33,652 INFO [org.jboss.cache.TreeCache] returning the transient state (140 bytes)
                        2006-04-07 17:02:33,652 INFO [org.jboss.cache.TreeCache] viewAccepted(): new members: [fn-harish:3359, fn-harish:3375]
                        2006-04-07 17:02:59,219 DEBUG [org.jboss.ha.framework.server.FarmMemberService] farmDeployments request, parentDUMap.size=2
                        2006-04-07 17:07:14,591 DEBUG [org.jboss.web.tomcat.tc5.session.JBossCacheManager] findSessions: find ids from cache store: [HIHB34LAjmpExQu0MJU4JA**]
                        2006-04-07 17:07:14,812 DEBUG [org.jboss.web.tomcat.tc5.session.JBossCacheManager] loadSession(): id= HIHB34LAjmpExQu0MJU4JA**, session=AttributeBasedClusteredSession[HIHB34LAjmpExQu0MJU4JA**.node2]
                        2006-04-07 17:08:12,977 DEBUG [org.jboss.web.tomcat.tc5.session.JBossCacheService] nodeDirty(): session in-memory data is invalidated with id: HIHB34LAjmpExQu0MJU4JA** and verion id: 4
                        2006-04-07 17:09:25,432 INFO [org.jboss.cache.TreeCache] viewAccepted(): new members: [fn-harish:3359]
                        2006-04-07 17:09:25,993 DEBUG [org.jboss.ha.framework.server.DistributedReplicantManagerImpl.DefaultPartition] notifyKeyListeners
                        2006-04-07 17:09:25,993 DEBUG [org.jboss.ha.framework.server.DistributedReplicantManagerImpl.DefaultPartition] notifying 1 listeners for key change: jboss.ha:service=HASingletonDeployer
                        2006-04-07 17:09:25,993 DEBUG [org.jboss.ha.singleton.HASingletonController] partitionTopologyChanged, isElectedNewMaster=true, isMasterNode=true, viewID=111133493
                        2006-04-07 17:09:25,993 DEBUG [org.jboss.ha.framework.server.DistributedReplicantManagerImpl.DefaultPartition] notifyKeyListeners
                        2006-04-07 17:09:26,003 DEBUG [org.jboss.ha.framework.server.DistributedReplicantManagerImpl.DefaultPartition] notifying 1 listeners for key change: DCacheBridge-DefaultJGBridge
                        2006-04-07 17:09:26,003 DEBUG [org.jboss.cache.invalidation.bridges.JGCacheInvalidationBridge] The list of replicant for the JG bridge has changed, computing and updating local info...
                        2006-04-07 17:09:26,003 DEBUG [org.jboss.cache.invalidation.bridges.JGCacheInvalidationBridge] ... No bridge info was associated to this node
                        2006-04-07 17:09:26,013 DEBUG [org.jboss.cache.invalidation.bridges.JGCacheInvalidationBridge] Updating list of invalidation groups that are bridged...
                        2006-04-07 17:09:26,013 DEBUG [org.jboss.cache.invalidation.bridges.JGCacheInvalidationBridge] ... nothing needs to be bridged.
                        2006-04-07 17:09:26,013 DEBUG [org.jboss.ha.framework.server.DistributedReplicantManagerImpl.DefaultPartition] notifyKeyListeners
                        2006-04-07 17:09:26,013 DEBUG [org.jboss.ha.framework.server.DistributedReplicantManagerImpl.DefaultPartition] notifying 1 listeners for key change: HAJNDI
                        2006-04-07 17:09:26,013 DEBUG [org.jboss.ha.framework.server.HARMIServerImpl$RefreshProxiesHATarget] replicantsChanged 'HAJNDI' to 1 (intra-view id: 111133493)
                        2006-04-07 17:09:26,023 INFO [org.jboss.ha.framework.interfaces.HAPartition.lifecycle.DefaultPartition] New cluster view for partition DefaultPartition (id: 2, delta: -1) : [10.224.0.74:1099]
                        2006-04-07 17:09:26,023 DEBUG [org.jboss.ha.framework.interfaces.HAPartition.DefaultPartition] dead members: [10.224.0.74:31099]
                        2006-04-07 17:09:26,023 DEBUG [org.jboss.ha.framework.interfaces.HAPartition.DefaultPartition] membership changed from 1 to 1
                        2006-04-07 17:09:26,023 DEBUG [org.jboss.ha.framework.interfaces.HAPartition.DefaultPartition] Begin notifyListeners, viewID: 2
                        2006-04-07 17:09:26,023 DEBUG [org.jboss.ha.framework.interfaces.HAPartition.DefaultPartition] End notifyListeners, viewID: 2
                        2006-04-07 17:09:26,023 DEBUG [org.jboss.ha.framework.interfaces.HAPartition.DefaultPartition] Begin notifyListeners, viewID: 2
                        2006-04-07 17:09:26,023 INFO [org.jboss.ha.framework.server.DistributedReplicantManagerImpl.DefaultPartition] I am (10.224.0.74:1099) received membershipChanged event:
                        2006-04-07 17:09:26,023 INFO [org.jboss.ha.framework.server.DistributedReplicantManagerImpl.DefaultPartition] Dead members: 1 ([10.224.0.74:31099])
                        2006-04-07 17:09:26,023 INFO [org.jboss.ha.framework.server.DistributedReplicantManagerImpl.DefaultPartition] New Members : 0 ([])
                        2006-04-07 17:09:26,023 INFO [org.jboss.ha.framework.server.DistributedReplicantManagerImpl.DefaultPartition] All Members : 1 ([10.224.0.74:1099])
                        2006-04-07 17:09:26,023 DEBUG [org.jboss.ha.framework.interfaces.HAPartition.DefaultPartition] End notifyListeners, viewID: 2

                        node2 log after shutdown

                        2006-04-07 17:07:02,233 INFO [STDOUT] <Apr 7, 02006 5:07.02.233 PM> : TP-Processor3 : FN_IS_ISInterfaceImpl : FN_IS_ISInterfaceImpl(): Exiting from the method.
                        2006-04-07 17:09:24,261 INFO [org.apache.coyote.http11.Http11Protocol] Pausing Coyote HTTP/1.1 on http-0.0.0.0-38080
                        2006-04-07 17:09:25,322 INFO [org.apache.juddi.registry.RegistryServlet] jUDDI Stopping: Cleaning up existing resources.
                        2006-04-07 17:09:25,342 INFO [org.apache.coyote.http11.Http11Protocol] Stopping Coyote HTTP/1.1 on http-0.0.0.0-38080
                        2006-04-07 17:09:25,853 INFO [jacorb.orb] prepare ORB for shutdown...
                        2006-04-07 17:09:25,853 INFO [jacorb.orb] ORB going down...
                        2006-04-07 17:09:25,863 INFO [jacorb.orb] ORB shutdown complete
                        2006-04-07 17:09:25,873 INFO [jacorb.orb] ORB run, exit

                        Thanks
                        regards
                        Nikhil

                        • 11. Re: Session is not getting replicated on JBoss-4.0.2
                          Brian Stansberry Master

                          Re: paid support, you can learn more about our support services at http://www.jboss.com/services/profsupport.

                          Looking at your logs, it seems to me the session replicated from node2 to all.

                          2006-04-07 17:07:14,591 DEBUG [org.jboss.web.tomcat.tc5.session.JBossCacheManager] findSessions: find ids from cache store: [HIHB34LAjmpExQu0MJU4JA**]
                          2006-04-07 17:07:14,812 DEBUG [org.jboss.web.tomcat.tc5.session.JBossCacheManager] loadSession(): id= HIHB34LAjmpExQu0MJU4JA**, session=AttributeBasedClusteredSession[HIHB34LAjmpExQu0MJU4JA**.node2]
                          2006-04-07 17:08:12,977 DEBUG [org.jboss.web.tomcat.tc5.session.JBossCacheService] nodeDirty(): session in-memory data is invalidated with id: HIHB34LAjmpExQu0MJU4JA** and verion id: 4


                          • 12. Re: Session is not getting replicated on JBoss-4.0.2
                            Nikhil Goel Newbie

                            Thanks Brian

                            Thanks for replying.

                            But my session is still not getting replicated.When I shutdown the server which is handling the request then my application asks me to login again.

                            Can you suggest me something else. What should I do?

                            Waiting for ur reply.

                            Thanks in advance.