2 Replies Latest reply on Dec 7, 2006 6:37 AM by Endolf Endolf

    Hanging on to RMI threads

    Endolf Endolf Newbie

      Hi

      Tried this on an empty 4.0.2 and a 4.0.5.GA setup, also tried jgroups 2.4.0.GA in the 4.0.5.GA containers.

      We are tracking down an infrequent OutOfMemoryExceptionon our JBoss app servers (It occurs every few months, we have 2 gig in each machine, so it's a slow leak, but does eventually cause an issue). We are running in a multi tiered, clustered environment. We have multiple versions of our software deployed at a time, so we have isolated class loading enabled. In 4.0.5.GA we tried CallByValue to true, and in 4.0.2 we tried it set to false.

      I tried setting up empty containers, clustered in their own partition so as not to conflict with out existing containers. I get the netbeans profiler installed and after a weekends uptime found ~350 RMI ConnectionExpiration and RMI TCP Connection threads.

      The fact that this is in an empty JBoss container suggests it's not our code. I've tried hunting google and JIRA but can't seem to find anyone else referencing similar issues. It should be easy to reproduce.

      We have tried JDK 1.5.0_03 and 1.5.0_09. This is all running on linux.

      Thanks

        • 1. Re: Hanging on to RMI threads
          Bela Ban Master

          Are you running a config of JGroups with flow control (FC) ? Try fc-fast-minimalthreads.xml from the JGroups src code of the version you are running.

          • 2. Re: Hanging on to RMI threads
            Endolf Endolf Newbie

            Hi

            I couldn't find a copy of that configuration anywhere. I did find another minimalthreads configuration xml file and noted that the up_thread and down_thread parameters seem to be the change. I've tried this, and it does seem to have stopped the leak we were seeing. However, we now have PingSender and PingWaiter threads leaking out at an even faster rate. Could you post a link to where I can get that configuration file to try?. I'm going to try setting the PING protocol threads back to true and see if that helps.

            Thanks