1 Reply Latest reply on Aug 2, 2007 4:08 AM by Carsten Rudat

    Failover not working InvalidClassException (Log4JLogger)

    Carsten Rudat Novice

      Hi all,

      I have a smal cluster of 2 JBoss 4.2.1.GA running and I tried to test a transparent failover (e.g. stopping node2). It seems that JBoss tried to load the session on node1, but that fails with:

      [JBossCacheService] loadSession(): id: oCzamsCP7SqX7LZBJiaYWA**exception occurred during serialization: java.io.InvalidClassException: org.apache.commons.logging.impl.Log4JLogger; local class incompatible: stream classdesc serialVersionUID = 1, local class serialVersionUID = 2930996631104246328


      Is there a problem having a Log variable in JSF-managed-beans or other pojos used in my tomcat-container?

      Could you give me a tip, what I should do?

      Thanks,
      Carsten

        • 1. Re: Failover not working InvalidClassException (Log4JLogger)
          Carsten Rudat Novice

          Hi,

          I fixed this - I had a commons-logging-x.jar in my WEB-INF/lib.

          But after removing this, I get another error:


          WARN [TreeCache] node /JSESSION/localhost/genloop-demo/8gZM8DrZOd0IGqYY6C3Luw** not found

          I have two jboss-4.2.1.GA (./run.sh -c all -b ip_node1/ip_node2) running. After shutting down node1 and submitting a request, I get this error on node2.
          What does this "localhost" mean and how can I get a session-string that allows transparent failover?

          To add some information, I run a JSF-application with tomahawk and client-side saving (javax.faces.STATE_SAVING_METHOD - client).

          Thanks for any help to get this work.
          Carsten