1 Reply Latest reply on Aug 8, 2007 10:26 PM by Larry Ludlow

    Using a WebServer and mod_jk 1.2.23 with Jboss 4.2.0GA

    Eric Gandt Newbie

      I can setup Apache without issue and mod_jk is working there (ie jkstatus is working), and knows where it should connect to now the problem is setting up JBOSS 4.2.0GA to listen for a connection via ajp13.

      First off I'm using the default Server instance
      Next I edited the file: default/deploy/jboss-web.deployer/META-INF/jboss-service.xml I located:
      false
      and changes it to true :
      true
      Next I added a new Engine line to this file:
      <Engine name=?jboss.web? defaultHost=?localhost? jvmRoute=?node1?>
      where node1 is described in workers.properties

      When I start up I get an error:
      11:47:44,605 ERROR [STDERR] [Fatal Error] jboss-service.xml:145:20: Open quote is expected for attribute "name" associated with an element type "Engine".
      11:47:44,608 ERROR [MainDeployer] Could not initialise deployment: file:/u01/software/Apps/701/jboss-4.2.0.GA/cs701_edit/server/default/deploy/jboss-web.deployer/
      org.jboss.deployment.DeploymentException: Open quote is expected for attribute "name" associated with an element type "Engine".; - nested throwable: (org.xml.sax.SAXParseException: Open quote is expected for attribute "name" associated with an element type "Engine".)
      at org.jboss.deployment.SARDeployer.init(SARDeployer.java:217)
      at org.jboss.deployment.MainDeployer.init(MainDeployer.java:872)
      at org.jboss.deployment.MainDeployer.deploy(MainDeployer.java:809)
      at org.jboss.deployment.MainDeployer.deploy(MainDeployer.java:782)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)


      I looked at the existing documentation for setting up a cluster, but it all seems for 3.X or 4.0, the only reference I found for 4.2 was at http://www.hishboy.com/index.php/2007/06/19/jboss-420ga-clustering-on-ubuntu-fiesty-704/
      but these are the instructions that are causing problems. Since Apache starts I'm assuming that I do not care about that yet, I want JBOSS 4.2.0GA to start properly.

      Thanks,
      ERIC

        • 1. Re: Using a WebServer and mod_jk 1.2.23 with Jboss 4.2.0GA
          Larry Ludlow Newbie

          Hope this helps.

          <Engine name="jboss.web" defaultHost="localhost" jvmRoute="tes1">
          



          11:47:44,608 ERROR [MainDeployer] Could not initialise deployment: file:/u01/software/Apps/701/jboss-4.2.0.GA/cs701_edit/server/default/deploy/jboss-web.deployer/
          org.jboss.deployment.DeploymentException: Open quote is expected for attribute "name" associated with an element type "Engine".; - nested throwable: (org.xml.sax.SAXParseException: Open quote is expected for attribute "name" associated with an element type "Engine".)


          JBoss is expecting the values to be within quotes (I make this mistake often).

          Also I don't think clustering will work with the default server config, you should try using the all configuration.

          I did this, and just removed what I didn't need.