0 Replies Latest reply on Sep 21, 2007 3:01 PM by i gain

    JMS Clustering problem

    i gain Newbie

      Hi All,

      I am using jboss-4.2.0.GA clustering on linux machine, I have QA environment configured in cluster and dev environment as standalone.

      3 Jboss Nodes are there in QA environment with
      partition name as QA-Cluster, I modified the UDP multicast port only on QA jboss nodes to keep them seprate from other cluster or server in the netwrok.

      1 Jboss Nodes is there in Dev environment which is standalone server.

      Once i deploy the application in dev env and and try to post msg on queue destination it goes to QA servers, I am not able to figure out what's wrong.

      I am not using hard coded QA server's ip in my code, i am using jboss.bind.address property to figure out the server's ip but still it goes to one of the QA server.

      I tried to run server in default mode which is not clustered, tried to run the same code which is looking up queue on HA-JNDI 1100 port, i get exception which is fine but it tries to lookup from QA server's ip and port, where as it should lookup from dev server's ip and port.


      I did check my dev server configuration and UDP multicast port is different from QA server UDP port and even partition name is also different in dev.

      Can anybody tell what could be the possible reason ?