1 Reply Latest reply on Oct 7, 2008 1:22 PM by Hubert Holierhoek

    HASingletonDeployer barrier unresolved in 5.0CR2

    Hubert Holierhoek Newbie

      I'm having trouble getting my singletons to work after migrating to 5.0 (from 4.2.1).

      I have the prescribed @Depends("jboss.ha:service=HASingletonDeploy,type=Barrier") on my beans (MDB, Mgmt, doesn't matter) but at startup I get:

      *** CONTEXTS MISSING DEPENDENCIES: Name -> Dependency{Required State:Actual State}
      
      jboss.j2ee:ear=tpa.ear,jar=tpaplatform.jar,name=TopologyDiscoveryListener,service=EJB3
       -> <UNKNOWN jboss.j2ee:ear=tpa.ear,jar=tpaplatform.jar,name=TopologyDiscoveryListener,service=EJB3>{Described:** UNRESOLVED Demands 'jboss.ha:service=HASingletonDeployer,type=Barrier' **}


      I can see the barrier service in the JMX console after startup.

      I've also tried starting up without my ear deployed, then hot-deploying it after I verify that the barrier has shown up in the JMX console, but I get the same error.

      Note that the particular ones I'm trying now used to be deployed in the deploy-hasingleton directory under 4.2.1, but have been updated to use the barrier method instead. Under 4.2.1 I had many other beans using the barrier method with no problems, however.

      Has something changed in 5.0 with regard to singletons? I haven't found anyone else having such problems so I suspect there's something I'm doing wrong here.