1 Reply Latest reply on Oct 2, 2009 3:53 AM by justkeys

    HA Singleton service lookup in cluster


      2 instances of Jboss AS 4.2.3GA running on different machines
      One HA-Singleton (type Barrier) service is deployed on both nodes, and is responsible to perform some operation.
      One SLSB using our service to perform some operation and is clustered.
      One application, that calls the method of session bean.

      My client is calling the session bean to fire an event and to perform some operations of my HA singleton service.

      Now my problem is that, when i tried to call the session beans method, on one of the node it says my HA service is not bound while on other it performs the operation.
      I even tried to look-up the HA service using RMIAdaper in my session bean but still it says service not bound.

        • 1. Re: HA Singleton service lookup in cluster

          If the SLSB depends on the cluster-wide singleton (due to eg @EJB IYoursingleton ... in its implementation class) then it "becomes a cluster-wide singleton" of its own. To make this SLSB available on all nodes, remove the @EJB, and perform a HA lookup (manually, without injection) whenever you need to talk to the singleton.