4 Replies Latest reply on Apr 7, 2006 7:06 AM by Teodor Buburuzan

    Module type is not compatible?

    Teodor Buburuzan Newbie

      Hi,

      I have installed Eclipse 3.1 with the Lombox 3.1RC2 plugin running with Jboss 4.0.2. I try to create a new Enterprise Application with one EJB Project (ejbmod) and one Dynamic Web Project (webmod). Lomboz creates the 3 projects (webmod, ejbmod and the EAR which should be deployed on the server). But when I try to add it to a new server (jboss 4.0.x Server) I get a Module type is not compatible!!! error and I cannot deploy anything on the server.
      It is strange that, if I create a Dynamic Web Project alone and one EJB Project, I am able to deploy them on the server. The problem arises only when they are bound together in an Enterprise Application (EAR module), which I must do in order for the webmod to have access to the ejbmod...

      What do I have to do to get it working? Is this a bug in Lomboz?
      The ejbmod is version 2.1, the webmod is 2.4 and the earmod is 1.4... All of them should be supported by Jboss4.0.2 !!! I have also tried with 2.0, 2.3 and 1.3... The same thing...

      Thanks.
      Teo