3 Replies Latest reply on Dec 7, 2009 11:35 AM by Philip Eisenhardt

    XPath in Riftsaw2.0 M2?

    Philip Eisenhardt Newbie

      I worked with glassfish/openESB, now I have to move to jboss+riftsaw.
      I modified one of the samples
      In my existing BPEL scripts I have this syntax

      test
      $CreateItemIn.createItem/arg0/@transactionId

      as a result I´d expect that my soap body contains something like this:
      <ns1:createItem>
      <arg0 transactionId="test" ...>
      ...
      but the soap body is this (on M1, M2 is the same message)
      <soapenv:Body>test</soapenv:Body>

      WS-BPEL 2.0 should be capable of interpreting the given syntax.

      I also tried this syntax
      arg0/@transactionId
      but this doesn´t help..

      If I generate the BPEL from the scratch (with Eclipse+JBoss Tool) the BPEL editor generates something like this:
      <bpel:to part="createItem" variable="CreateItemIn">
      <bpel:query queryLanguage="urn:oasis:names:tc:wsbpel:2.0:sublang:xpath1.0"><![CDATA[arg0/@transactionId]]></bpel:query>
      </bpel:to>

      I have tried two different environments
      JBoss 5.1.0+riftsaw 2.0 M1
      JBoss 5.1.0+riftsaw 2.0 M2

      Am I missing something? I assume I just have to use a slightly different syntax in my BPEL...

      Phil