1 Reply Latest reply on Sep 11, 2004 9:37 AM by Scott Stark

    JVM Parameters in run.bat

    cjain75 Newbie

      I am using Jboss 3.2.5 with the following options set in the run.bat file.

      set JAVA_OPTS=%JAVA_OPTS% -server -Xdebug -Xms512m -Xmx512m -XX:MaxPermSize=128m -XX:+AggressiveHeap

      & when i start Jboss using these parameters it throws the following error.


      JBoss Bootstrap Environment
      .
      JBOSS_HOME: E:\jboss-3.2.5\bin\\..
      .
      JAVA: E:\jdk1.4.2_05\bin\java
      .
      JAVA_OPTS: -Dprogram.name=run.bat -Xloggc:E:/jboss-3.2.5/server/default/log/jboss-gc.txt -server -Xdebug -Xms128m -Xmx128m
      -XX:MaxPermSize=128m -XX:+AggressiveHeap
      .
      CLASSPATH: E:\jdk1.4.2_05\lib\tools.jar;E:\jboss-3.2.5\bin\\run.jar
      .
      ===============================================================================
      .
      17:58:00,359 INFO [Server] Starting JBoss (MX MicroKernel)...
      17:58:00,359 INFO [Server] Release ID: JBoss [WonderLand] 3.2.5 (build: CVSTag=JBoss_3_2_5 date=200406251954)
      17:58:00,359 INFO [Server] Home Dir: E:\jboss-3.2.5
      17:58:00,359 INFO [Server] Home URL: file:/E:/jboss-3.2.5/
      17:58:00,359 INFO [Server] Library URL: file:/E:/jboss-3.2.5/lib/
      17:58:00,359 INFO [Server] Patch URL: null
      17:58:00,359 INFO [Server] Server Name: default
      17:58:00,359 INFO [Server] Server Home Dir: E:\jboss-3.2.5\server\default
      17:58:00,375 INFO [Server] Server Home URL: file:/E:/jboss-3.2.5/server/default/
      17:58:00,375 INFO [Server] Server Data Dir: E:\jboss-3.2.5\server\default\data
      17:58:00,375 INFO [Server] Server Temp Dir: E:\jboss-3.2.5\server\default\tmp
      17:58:00,375 INFO [Server] Server Config URL: file:/E:/jboss-3.2.5/server/default/conf/
      17:58:00,375 INFO [Server] Server Library URL: file:/E:/jboss-3.2.5/server/default/lib/
      17:58:00,375 INFO [Server] Root Deployment Filename: jboss-service.xml
      17:58:00,375 INFO [Server] Starting General Purpose Architecture (GPA)...
      17:58:01,078 INFO [ServerInfo] Java version: 1.4.2_05,Sun Microsystems Inc.
      17:58:01,078 INFO [ServerInfo] Java VM: Java HotSpot(TM) Server VM 1.4.2_05-b04,Sun Microsystems Inc.
      17:58:01,078 INFO [ServerInfo] OS-System: Windows 2000 5.0,x86
      17:58:01,906 INFO [Server] Core system initialized
      17:58:08,187 INFO [Log4jService$URLWatchTimerTask] Configuring from URL: resource:log4j.xml
      17:58:09,031 INFO [WebService] Using RMI server codebase: http://chetan:8083/
      17:58:09,234 INFO [NamingService] Started jnpPort=1099, rmiPort=1098, backlog=50, bindAddress=/0.0.0.0, Client SocketFactory
      =null, Server SocketFactory=org.jboss.net.sockets.DefaultSocketFactory@ad093076
      #
      # HotSpot Virtual Machine Error, Internal Error
      # Please report this error at
      # http://java.sun.com/cgi-bin/bugreport.cgi
      #
      # Java VM: Java HotSpot(TM) Server VM (1.4.2_05-b04 mixed mode)
      #
      # Error happened during: parallel gc system gc
      #
      # Error ID: 50532D41524B33574545500E435050011A
      #
      # Thread requesting VM operation: prio=2 tid=0x21fcac00 nid=0x7e8 runnable
      #

      Heap at VM Abort:
      Heap
      PSYoungGen total 44032K, used 35520K [0x10010000, 0x13010000, 0x13010000)
      eden space 7488K, 13% used [0x10010000,0x10110060,0x10760000)
      from space 36544K, 94% used [0x10760000,0x12910000,0x12b10000)
      to space 5120K, 0% used [0x12b10000,0x12b10000,0x13010000)
      PSOldGen total 81920K, used 0K [0x13010000, 0x18010000, 0x18010000)
      object space 81920K, 0% used [0x13010000,0x13010000,0x18010000)
      PSPermGen total 16384K, used 6620K [0x18010000, 0x19010000, 0x20010000)
      object space 16384K, 40% used [0x18010000,0x18687360,0x19010000)
      Press any key to continue . . .



      ===============================================================================

      but when i remove the option of -Xdebug then Jboss starts up without any errors.

      Am i setting wrong values for Memory Settings. ??? Any help in this regards is appreciated

      Regards,
      Chetan.