10 Replies Latest reply on May 27, 2009 4:13 PM by vony jon

    verbose GC not working

    vony jon Newbie

      Hi,

      I am trying to get the GC output using following switches in JVM

      JAVA_OPTS="-server -Xms1500m -Xmx1500m -Xss128k -verbosegc -Xloggc:GC.log -XX:+PrintGCTimeStamps -XX:+PrintGCDetails -XX:+UseLargePages -XX:PermSize=512m -XX:MaxPermSize=512m -XX:ThreadStackSize=512 -XX:+UseParallelGC -XX:+AggressiveHeap -XX:CompileThreshold=100 -XX:SurvivorRatio=8 -XX:TargetSurvivorRatio=90 -XX:MaxTenuringThreshold=31"

      But GC.log doesn't seems to be generating.

      My environment is JDK 1.5 update 12
      OS: RHEL Linux
      Jboss 4.2.0

      Thanks

        • 1. Re: verbose GC not working
          Larry Jiang Newbie

          -verbosegc?
          should be -verbose:gc

          • 2. Re: verbose GC not working
            Peter Johnson Master

            The JVM will refuse to run if it does not recognize an option. If jtcnz is correct and you have a typo, then this setting for JAVA_OPTS is no being picked up. When you run run.sh, it echoes the JAVA_OPTS - are these settings there?

            • 3. Re: verbose GC not working
              Peter Johnson Master

              Correction, the JVM will run with the "-verbosegc" typo. Apparently, it will accept any option that begins with "-verbose", but ignore that option if it is not completed correctly.

              • 4. Re: verbose GC not working
                vony jon Newbie

                Sorry my bad
                it was typo mistake at my end. I did correct it to "-verbose:gc".

                But still I am not able to GC.log

                • 5. Re: verbose GC not working
                  Peter Johnson Master

                  Please answer this:

                  When you run run.sh, it echoes the JAVA_OPTS - are these settings there?


                  • 6. Re: verbose GC not working
                    vony jon Newbie

                    Hi Peter,

                    Yes it is echoing the JAVA_OPTS, even i just did grep the java process and it shows all the JAVA_OPTS i mentioned in my run.conf

                    root 7176 7167 9 10:03 pts/1 00:02:32 /usr/java/jdk1.5.0_12/bin/java -Dprogram.name=run.sh -server -Xms1500m -Xmx1500m -Xss128k -verbose:gc -Xloggc:GC.log -XX:+PrintGCTimeStamps -XX:+PrintGCDetails -XX:+UseLargePages -XX:PermSize=512m -XX:MaxPermSize=512m -XX:ThreadStackSize=512 -XX:+UseParallelGC -XX:+AggressiveHeap -XX:CompileThreshold=100 -XX:SurvivorRatio=8 -XX:TargetSurvivorRatio=90 -XX:MaxTenuringThreshold=31 -Dcom.sun.management.jmxremote -Dcom.sun.management.jmxremote.port=12345 -Dcom.sun.management.jmxremote.authenticate=false -Dcom.sun.management.jmxremote.ssl=false -Djava.net.preferIPv4Stack=true -Djava.endorsed.dirs=/opt/jboss-4.2.0.GA/lib/endorsed -classpath /opt/jboss-4.2.0.GA/bin/run.jar:/usr/java/jdk1.5.0_12/lib/tools.jar org.jboss.Main -c all -g mydev -u 228.1.2.222 -b 192.168.1.210 -Dapplication=ET
                    
                    


                    • 7. Re: verbose GC not working
                      vony jon Newbie

                      Hi Peter,

                      One more thing when run jboss on windows machine with same settings that i provided on linux it does generate GC.log.

                      However it is not generating on Linux, i did check the folder permission as well and i am running this process as a root and root has read/write permission on all the folder under jboss folder structure.

                      • 8. Re: verbose GC not working
                        Peter Johnson Master

                        Looks like you are running JBoss AS as a service, as root. Since you did not give a full path name for the gc log file, it will be placed into the "current working directory." Since you are running JBoss AS as a service I am not sure exactly what the current working directory is, but I would look in /root/GC.log. If it is not there, you might have to search your disks looking for it.

                        I recommend that you specify a full path name, such as "-Xloggc:/opt/jboss-4.2.0.GA/bin/GC.log".

                        • 9. Re: verbose GC not working
                          Peter Johnson Master

                          On Windows did your run as a service? You'll have fun trying to find the GC.log file there also if you did...

                          • 10. Re: verbose GC not working
                            vony jon Newbie

                            Hi Peter,

                            Yeah I am running jboss as a service on linux On windows i did not run as a service

                            Yes you are right i checked /root dir and GC.log is there...:)


                            Thanks a lot Peter.