7 Replies Latest reply on Jun 28, 2002 3:55 AM by Christoph Grimm

    JBoss.net and Cataline

    Markus Menner Newbie

      Hi there,

      I tried to install JBoss.net with Cataline using the CVS snapshot as of 04/24/2002.

      I changed


      jboss.web:service=Jetty
      axis
      java:/jaas/other


      to


      jboss.web:service=EmbeddedCatalinaSX
      axis
      java:/jaas/other


      which didn't lead to the expected result, that the AxisServlet got deployed.

      With Jetty everything works fine, but I have to use Tomcat, because I need a certain compression filter.

      I noticed, that there was an attribute "WarDeployerName" earlier which isn't accepted any more?!

      TX

        • 1. Re: JBoss.net and Cataline
          Dr. Christoph Georg Jung Newbie

          Hi too,

          the WarDeployerName is no more needed, because AxisService will look for any registered WebApplicationDeployer ... I guess that the way the DeploymentInfo is setup doesn´t suite the way EmbeddedCatalina likes to deploy web applications?

          I´ve got that on my tasklist anyway, but if you want to speed up the process, why don´t you debug into
          the AxisService.startService method to find out
          whether it is finding the right SubDeployer and trace
          the setting up of the DeploymentInfo?

          Tx too,
          CGJ



          • 2. Re: JBoss.net and Catalina
            Markus Menner Newbie

            Hi,

            I went another way: I changed things to work with Jetty ... ;-)

            Now I've setup everything to work with my framework and I must say, that JBoss.net is really, really cooooool. Congratulations!

            Nevertheless, I noticed a little problem with the "hot" deployment of web services:

            I'm deploying the .wsr standalone (not inside an .ear). The first time everything works fine, but further deployments are ignored (nothing happens).

            Deleting the .wsr and then copying the new one in the deployment directory leads to an error message, that this service is allready deployed.

            I have to restart JBoss and then the deployment succeeds.

            Anyway, it's a small problem ...

            TX
            Markus

            • 3. Re: JBoss.net and Catalina
              Dr. Christoph Georg Jung Newbie

              a good choice ;-)

              I will have a look at the hot-deploy stuff first. Catalina will follow before going final, I promise.

              CGJ

              • 4. Re: JBoss.net and Cataline
                Denis Robert Newbie

                I believe the problem with Catalina might be simple (I might be wrong, as I haven't had the time yet to plough through the source...):

                1. in the .sar file, the jboss-service.xml descriptor defines the Axis service as depending on Jetty; this would prevent the Axis from automatically starting up since it's looking for a non-existent service.

                2. The deployer attempts to deploy the service under the "/&RootContext;/*" context. This is not what Catalina expects. It would probably respond better to a context of the form "/&RootContext;".

                As I said, I haven't looked at the source and I could be completely in left field, but it could be worth a try...

                • 5. Re: JBoss.net and Cataline
                  Dr. Christoph Georg Jung Newbie

                  Hi robert,

                  I will try this suggestion out. (First need to get a catalina distro :-)

                  CGJ

                  • 6. Re: JBoss.net and Cataline
                    Christoph Grimm Newbie

                    Christoph,

                    the problem with catalina still seems to exist with JBOSS 3.0.0

                    here's the part of the server log:

                    08:46:21,687 INFO [AxisService] About to deploy axis web application from org.jboss.deployment.DeploymentInfo@292deb12{url=http://net.jboss.org/fake.war } under context /axis/*.
                    08:46:21,717 INFO [EmbeddedCatalinaServiceSX] deploy, ctxPath=/axis/*, warUrl=file:/D:/devtools/jboss-3.0.0/server/default/tmp/deploy/_axis_/axis/
                    08:46:21,727 INFO [Engine] WebappLoader[/axis/*]: Deploying class repositories to work directory D:\devtools\jboss-3.0.0\catalina\work\localhost\axis_*
                    08:46:21,737 INFO [Engine] StandardManager[/axis/*]: Seeding random number generator class java.security.SecureRandom
                    08:46:21,737 INFO [Engine] StandardManager[/axis/*]: Seeding of random number generator has been completed
                    08:46:21,927 INFO [Engine] ContextConfig[/axis/*]: Added certificates -> request attribute Valve
                    08:46:21,937 INFO [Engine] ContextConfig[/axis/*]: Configured an authenticator for method BASIC08:46:22,017 INFO [EmbeddedCatalinaServiceSX] Using Java2 parent classloader delegation: true
                    08:46:22,017 INFO [Engine] StandardWrapper[/axis/*:default]: Loading container servlet default
                    08:46:22,027 INFO [Engine] default: init
                    08:46:22,027 INFO [Engine] StandardWrapper[/axis/*:invoker]: Loading container servlet invoker
                    08:46:22,027 INFO [Engine] invoker: init
                    08:46:22,027 INFO [Engine] jsp: init
                    08:46:22,027 INFO [Engine] The scratchDir you specified: D:\devtools\jboss-3.0.0\catalina\work\localhost\axis_* is unusable.

                    • 7. Re: JBoss.net and Cataline
                      Christoph Grimm Newbie

                      Christoph,

                      i still have problems starting jboss.net & cataline, using release 3.0

                      this is the server log i get:

                      08:46:21,687 INFO [AxisService] About to deploy axis web application from org.jboss.deployment.DeploymentInfo@292deb12{url=http://net.jboss.org/fake.war } under context /axis/*.
                      08:46:21,717 INFO [EmbeddedCatalinaServiceSX] deploy, ctxPath=/axis/*, warUrl=file:/D:/devtools/jboss-3.0.0/server/default/tmp/deploy/_axis_/axis/
                      08:46:21,727 INFO [Engine] WebappLoader[/axis/*]: Deploying class repositories to work directory D:\devtools\jboss-3.0.0\catalina\work\localhost\axis_*
                      08:46:21,737 INFO [Engine] StandardManager[/axis/*]: Seeding random number generator class java.security.SecureRandom
                      08:46:21,737 INFO [Engine] StandardManager[/axis/*]: Seeding of random number generator has been completed
                      08:46:21,927 INFO [Engine] ContextConfig[/axis/*]: Added certificates -> request attribute Valve
                      08:46:21,937 INFO [Engine] ContextConfig[/axis/*]: Configured an authenticator for method BASIC08:46:22,017 INFO [EmbeddedCatalinaServiceSX] Using Java2 parent classloader delegation: true
                      08:46:22,017 INFO [Engine] StandardWrapper[/axis/*:default]: Loading container servlet default
                      08:46:22,027 INFO [Engine] default: init
                      08:46:22,027 INFO [Engine] StandardWrapper[/axis/*:invoker]: Loading container servlet invoker
                      08:46:22,027 INFO [Engine] invoker: init
                      08:46:22,027 INFO [Engine] jsp: init
                      08:46:22,027 INFO [Engine] The scratchDir you specified: D:\devtools\jboss-3.0.0\catalina\work\localhost\axis_* is unusable.