2 Replies Latest reply on Sep 8, 2002 12:32 AM by John-Luc Bakker

    Problem with swap (3.0.1, Jetty, Axis beta1 to beta3)

    John-Luc Bakker Newbie

      Guys,

      I have a problem when swapping from Axis beta1 to beta3. This is what I did:

      -I replaced server/all/lib/axis.jar with the axis.jar that came with beta3.

      -I added jaxrpc.jar to server/all/lib/

      -I opened server/all/deploy/jboss-net.sar and looked for an axis.jar to replace but didn't found one. Instead, I modified meta-inf/jboss-service.xml and came up with: <classpath codebase="lib" archives="axis.jar, javax.servlet.jar, jaxrpc.jar"/>

      -Desperate, I added 'axis.jar', 'commons-logging.jar', and 'jaxrpc.jar' to classpath of jboss

      I still get:
      [org.jboss.deployment.DeploymentInfo@f2cb503 { url=file:/C:/javasoft/jboss-3.0.1
      /server/all/deploy/jboss-net.sar }
      deployer: org.jboss.deployment.SARDeployer@2d3205
      status: Deployment FAILED reason: org.apache.axis.deployment.wsdd.WSDDService.
      getQName()Ljavax/xml/rpc/namespace/QName;

      So, where do I screw things up?

      Best regards,

      John-Luc

        • 1. Re: Problem with swap (3.0.1, Jetty, Axis beta1 to beta3)
          Rob Newbie

          Some of the classes and Interfaces in axis changed from beta1 to beta3. One of the more notable changes is the package change for the QName class, they moved it into a different package in the javax.xml extention api. As well the WSDL stuff from IBM had their own Qname class that was used in the beta1 release but changed over to the javax.xml classes in the beta3 version. Some other classes that JBoss.net used in it's implementaion have also changed. So the end result comes down to you cannot just drop in the new axis api's and get it to work, it is dependent on beta1, for the time being anyway.

          • 2. Re: Problem with swap (3.0.1, Jetty, Axis beta1 to beta3)
            John-Luc Bakker Newbie

            Yes, I figured that out after trying to update JBoss.net 3.0.2 code to work with axis beta3. I came close but stopped fixing 10 errors short of successful compilation.

            Then I tried to compile with axis beta2 and I found that I had to update two lines of code to get it compiling. I didn't try to simply replace the axis b1 with b2; that may have worked without fixing the two lines.

            Bottom line, jboss.net 3.0.2 only works with axis b1 (and with b2 without EJB and perhaps only after fixing two lines). Not with b3 or RC.

            Thanks!

            John-Luc