6 Replies Latest reply on Nov 1, 2002 5:56 PM by Perot Developer

    Could not find .. testHelloWorld

    pchar Newbie

      Hi All
      i'm trying to deploy testHelloWorld.wsr (coming form http://www.csd.abdn.ac.uk/~bscharla/teaching/mtp_software/jboss/jboss-net-HelloWorld.shtml) but i call the url:
      http://localhost:8080/jboss-net/servlet/AxisServlet
      i get the exception:

      12:21:51,772 ERROR [JavaProvider] Exception:
      java.lang.ClassNotFoundException: testHelloWorld
      ...
      ...
      12:21:52,441 ERROR [Engine] StandardWrapperValve[JBossAxisServlet]: Servlet.service() for servlet JBossAxisServlet threw exception
      org.apache.axis.ConfigurationException: Could not find class for the service named: testHelloWorld
      Hint: you may need to copy your class files/tree into the right location (which depends on the servlet system you are using).
      AxisFault
      faultCode: {http://xml.apache.org/axis/}Server.generalException
      faultString: Could not find class for the service named: testHelloWorld
      Hint: you may need to copy your class files/tree into the right location (which depends on the servlet system you are using).
      faultActor: null
      faultDetail:

      Could not find class for the service named: testHelloWorld
      Hint: you may need to copy your class files/tree into the right location (which depends on the servlet system you are using).


      can somebody help me?

      thanks in advance for any suggestion
      patrick

        • 1. Re: Could not find .. testHelloWorld
          gernot Newbie

          control your web-service.xml file if the className parameter fits your setup. do you use a package for the class??
          by the way which jboss version are you using?

          c.u.
          gernot

          • 2. Re: Could not find .. testHelloWorld
            pchar Newbie

            My testHelloWorld.wsr
            contain:
            testHelloWorld.class
            and
            META-INF with:
            MANIFEST.MF
            web-service.xml:

            <!-- Example bare bones Web Service Deployment Descriptor -->
            <deployment
            xmlns="http://xml.apache.org/axis/wsdd/"
            xmlns:xsi="http://www.w3.org/2000/10/XMLSchema-instance"
            xmlns:java="http://xml.apache.org/axis/wsdd/providers/java">






            im using the http://www.csd.abdn.ac.uk/~bscharla/teaching/jboss-4.0.0alpha_tomcat-4.0.4.zip
            prebuild version.

            i dont really undestand what is wrong i this 2 files..:((

            • 3. Re: Could not find .. testHelloWorld
              gernot Newbie

              in the ant build.xml you are (should) using their is a comment:
              <!-- axis doesn't like it this way, so will wrap the wsr file in a war file -->

              so try to build the war,....

              c.u.
              gernot

              • 4. Re: Could not find .. testHelloWorld
                Perot Developer Newbie

                I am having the same problem. I tried using the war instead, as suggested, without luck.

                • 5. Re: Could not find .. testHelloWorld
                  Perot Developer Newbie

                  I found somewhat of a workaround. I noticed the JBOSS_CLASSPATH in the Jboss run.bat file is used to set the jre's classpath when running JBoss. So I added JBOSS_CLASSPATH as a system env variable, and set its value to point to %JBOSS_DIST%/server/deploy/
                  testHelloWorld.wsr. After shutting down JBoss and restarting (testHelloWorld.wsr MUST be in the deply folder before starting JBoss), I was able to use the links provided in the example without error:
                  http://localhost:8080/jboss-net/servlet/AxisServlet, and
                  http://localhost:8080/jboss-net/services/testHelloWorld?wsdl

                  ***HOWEVER, I was then not able to get the client to run. It returns this error:


                  Nov 1, 2002 11:52:38 AM org.apache.axis.client.Call invoke
                  INFO: Mapping Exception to AxisFault
                  AxisFault
                  faultCode: {http://xml.apache.org/axis/}HTTP
                  faultString: (500)No Context configured to process this request
                  faultActor: null
                  faultDetail:
                  null: return code: 500
                  &lt;html&gt;&lt;head&gt;&lt;title&gt;Apache Tomcat/4.0.4 - Error report&lt;/title&gt;&lt;STYLE&gt;&lt;!--H1{fo
                  nt-family : sans-serif,Arial,Tahoma;color : white;background-color : #0086b2;} BODY{font-family : sans-serif,A
                  rial,Tahoma;color : black;background-color : white;} B{color : white;background-color : #0086b2;} HR{color : #
                  0086b2;} --&gt;&lt;/STYLE&gt; &lt;/head&gt;&lt;body&gt;&lt;h1&gt;Apache Tomcat/4.0.4 - HTTP Status 500 - No Co
                  ntext configured to process this request&lt;/h1&gt;&lt;HR size=&quot;1&quot; noshade&gt;&lt;p&gt;&lt;b&gt;type
                  &lt;/b&gt; Status report&lt;/p&gt;&lt;p&gt;&lt;b&gt;message&lt;/b&gt; &lt;u&gt;No Context configured to proces
                  s this request&lt;/u&gt;&lt;/p&gt;&lt;p&gt;&lt;b&gt;description&lt;/b&gt; &lt;u&gt;The server encountered an i
                  nternal error (No Context configured to process this request) that prevented it from fulfilling this request.&
                  lt;/u&gt;&lt;/p&gt;&lt;HR size=&quot;1&quot; noshade&gt;&lt;/body&gt;&lt;/html&gt;

                  (500)No Context configured to process this request
                  at org.apache.axis.transport.http.HTTPSender.readFromSocket(HTTPSender.java:628)
                  at org.apache.axis.transport.http.HTTPSender.invoke(HTTPSender.java:129)
                  at org.apache.axis.strategies.InvocationStrategy.visit(InvocationStrategy.java:71)
                  at org.apache.axis.SimpleChain.doVisiting(SimpleChain.java:153)
                  at org.apache.axis.SimpleChain.invoke(SimpleChain.java:123)
                  at org.apache.axis.client.AxisClient.invoke(AxisClient.java:181)
                  at org.apache.axis.client.Call.invokeEngine(Call.java:2084)
                  at org.apache.axis.client.Call.invoke(Call.java:2073)
                  at org.apache.axis.client.Call.invoke(Call.java:1842)
                  at org.apache.axis.client.Call.invoke(Call.java:1768)
                  at org.apache.axis.client.Call.invoke(Call.java:1306)
                  at testClient1.main(testClient1.java:28)
                  (500)No Context configured to process this request

                  Any ideas?

                  • 6. Re: Could not find .. testHelloWorld
                    Perot Developer Newbie

                    I think I found the problem. The url in the testClientJava, "http://localhost:8070/axis/services/testHelloWorld", is incorrect. I changed it to "http://localhost:8070/jboss-net/services/testHelloWorld" and everything worked after that. The testClientJava code must be out of date.