5 Replies Latest reply on Feb 4, 2003 4:28 PM by Michael J. Bergin

    Incomplete Deployment on wsr file

    Ron Jawanda Novice

      I have a wsr file (axisxml.wsr) that contains
      WEB-INF
      classes
      lib
      In WEB-INF I have the web-services.xml file

      I get this message when I place it in the deploy directory

      NOTE: jboss-3.0.4
      Windows 2000 server
      web-services.xml is this
      --------Example EJB Web Service Descriptor -->

      <deployment name="SparePartName"
      targetNamespace="http://bmdrjawanda:8080/SparePartName"
      xmlns:SparePartName="http://bmdrjawanda:8080/SparePartName"

      xmlns="http://xml.apache.org/axis/wsdd/"
      xmlns:java="http://xml.apache.org/axis/wsdd/providers/java"
      xmlns:xsi="http://www.w3.org/2000/10/XMLSchema-instance">









      --------------------





      Error is this
      ------------------------


      12:44:44,759 INFO [MainDeployer] Deployment of package: file:/C:/data/swi/jboss
      -3.0.0/server/all/deploy/axisxml.wsr is waiting for an appropriate deployer.
      12:44:44,775 ERROR [URLDeploymentScanner] MBeanException: Exception in MBean ope
      ration 'checkIncompleteDeployments()'
      Cause: Incomplete Deployment listing:
      Packages waiting for a deployer:
      [org.jboss.deployment.DeploymentInfo@36f754b7 { url=file:/C:/data/swi/jboss-3.0.
      0/server/all/deploy/axisxml.wsr }
      deployer: null
      status: null
      state: INIT_WAITING_DEPLOYER
      watch: file:/C:/data/swi/jboss-3.0.0/server/all/deploy/axisxml.wsr
      lastDeployed: 1037814284759
      lastModified: 1037814284728




      mbeans:
      ]Incompletely deployed packages:
      [org.jboss.deployment.DeploymentInfo@36f754b7 { url=file:/C:/data/swi/jboss-3.0.
      0/server/all/deploy/axisxml.wsr }
      deployer: null
      status: null
      state: INIT_WAITING_DEPLOYER
      watch: file:/C:/data/swi/jboss-3.0.0/server/all/deploy/axisxml.wsr
      lastDeployed: 1037814284759
      lastModified: 1037814284728

        • 1. Re: Incomplete Deployment on wsr file
          Sean Radford Novice

          Does anyone know the cause of this, as I'm having the same problem - though I thought that the web-services.xml file goes in a META-INF directory.

          Regards,

          Sean

          • 2. Re: Incomplete Deployment on wsr file
            Davin Lindner-Green Newbie

            Hi, apology in advance, please be aware that I am still learning the facts with JBoss.net and Axis, and perhaps do not have this correct. Can someone corroborate this:

            POSTULATE: Axis 1.0 installed as a web app (axis.war directory in the <jboss home>/server/default/ directory as described in the Apache Axis Installation docs) *functions* under JBoss 3.0.x but does not *integrate* fully with the JBoss environment. In particular, wsr files will NOT hot deploy simply by placing in the deploy directory. Rather, use the Axis Installation docs suggested deployment method ie, put classes in the axis.war tree and run org.apache.clients.AdminClient to load your wsdd file.

            JBoss.net then includes Apache Axis *AND* integrates it fully with the JBoss environment, including the hot deploy of wsr files. However in Jboss 3.0.x Jboss.net is still in beta and has some problems (can anyone get all of the AdminServlet functions to work on Jboss.net? How about web service hooks to Stateless EJBs?).

            Solution: for my $.02, I will stick with Axis and leave Jboss.net alone for now, until 3.2 at least.

            Based on above postulate, I believe that you do not have Jboss.net installed but rather only Axis. Do you have jboss-net.sar in your deploy directory?

            • 3. Re: Incomplete Deployment on wsr file
              Sean Radford Novice

              I'm using JBoss 3.0.4/Jetty in 'all' configuration so that the jboss-net.sar is deployed (without any reports of error). I have then built a simple .wsr with a simple META-INF/web-service.xml:

              <deployment xmlns="http://xml.apache.org/axis/wsdd/"
              xmlns:java="http://xml.apache.org/axis/wsdd/providers/java">








              (The MyService class being nabbed from the axis examples)

              And I get the following on JBoss startup:

              12:45:05,650 INFO [MainDeployer] Starting deployment of package: file:/C:/java/jboss-3.0.4/server/all/deploy/ws-test.wsr/
              12:45:05,670 INFO [MainDeployer] deployment waiting for deployer: file:/C:/java/jboss-3.0.4/server/all/deploy/ws-test.wsr/
              12:45:05,670 INFO [MainDeployer] Deployment of package: file:/C:/java/jboss-3.0.4/server/all/deploy/ws-test.wsr/ is waiting for an
              appropriate deployer.
              12:45:05,710 ERROR [URLDeploymentScanner] MBeanException: Exception in MBean operation 'checkIncompleteDeployments()'
              Cause: Incomplete Deployment listing:
              Packages waiting for a deployer:
              [org.jboss.deployment.DeploymentInfo@70d3483b { url=file:/C:/java/jboss-3.0.4/server/all/deploy/ws-test.wsr/ }
              deployer: null
              status: null
              state: INIT_WAITING_DEPLOYER
              watch: file:/C:/java/jboss-3.0.4/server/all/deploy/ws-test.wsr/
              lastDeployed: 1041597905670
              lastModified: 1041597364512
              mbeans:
              ]Incompletely deployed packages:
              [org.jboss.deployment.DeploymentInfo@70d3483b { url=file:/C:/java/jboss-3.0.4/server/all/deploy/ws-test.wsr/ }
              deployer: null
              status: null
              state: INIT_WAITING_DEPLOYER
              watch: file:/C:/java/jboss-3.0.4/server/all/deploy/ws-test.wsr/
              lastDeployed: 1041597905670
              lastModified: 1041597364512
              mbeans:
              ]MBeans waiting for classes:

              MBeans waiting for other MBeans:


              12:45:05,981 INFO [URLDeploymentScanner] Started


              If I do as davlinlg suggests (above) and resort to following the Apache Axis install procedure of deploying all in a war and forgetting about the jboss-net.sar I get as I have posted here:

              http://www.jboss.org/modules/bb/index.html?module=bb&op=viewtopic&t=forums/ :-(

              Regards,

              Sean

              • 4. Re: Incomplete Deployment on wsr file
                Sean Radford Novice

                Needed to get JBoss 4 (currently in alpha in CVS)

                Sean

                • 5. Re: Incomplete Deployment on wsr file
                  Michael J. Bergin Newbie

                  i was having the same problem using the standard JBoss 3.0.4 release. i finally figured out that i had web-services.xml in my wsr file instead of web-service.xml. once i changed that the incomplete deployment went away.