3 Replies Latest reply on Jun 10, 2003 8:40 AM by Jon Barnett

    "Administer Axis" Error on Web Page

    John Tsimikas Newbie

      I've asked this before, but I will ask it again.

      Under jboss-3.2.1 & jboss-4.0.0DR1
      when I access the following URL

      http://localhost:8080/jboss-net

      I get the following web page

      --------------------------------------------------------
      Hello! Welcome to Apache-Axis.

      What do you want to do today?

      Administer Axis
      Visit the Axis Servlet
      --------------------------------------------------------


      When I click on the Administer Axis link I get
      the following error:


      --------------------------------------------------------
      HTTP ERROR: 503 java.lang.ClassNotFoundException: AdminServlet

      RequestURI=/jboss-net/servlet/AdminServlet

      --------------------------------------------------

      Does anybody know what is happening?
      This happens right after I cleanly install JBOSS
      and execute JBOSS as follows:

      run -c all.



      Thanks,
      John



        • 1. Re: "Administer Axis" Error on Web Page
          Jon Barnett Master

          There is no AdminServlet so there is a bug in the page. The access should be to AxisAdminServlet. Check the mappings in the server/all/deploy/jboss-net.sar/jboss-net.war/WEB-INF/web.xml of your distribution. You'll see there is no declaration for AdminServlet. Modify the page server/all/deploy/jboss-net.sar/jboss-net.war/index.html. The actual servlet class exists in server/all/deploy/jboss-net.sar/jboss-net.jar.

          • 2. Re: "Administer Axis" Error on Web Page
            John Tsimikas Newbie

            Thanks that worked.

            Would you happen to know if the the class

            org.apache.axis.client.AdminClient

            which is used to deploy web services in Axis can be used to deploy web services under JBOSS.NET on 3.2.0?

            Or do I have to build a WSR file to deploy a web service under JBOSS.NET.



            • 3. Re: "Administer Axis" Error on Web Page
              Jon Barnett Master

              I haven't really tried to deploy with JBoss.NET as we need clean Axis installs to support ports between WAS 5.0 and JBoss. Deployment of Web services becomes a bit complex since JBoss deployment becomes involved. It would probably be easier to use the WSR packing to deploy. Much of the standard Axis directory structure does not exist in JBoss.NET and that might hamper the standard AdminClient physical process.