6 Replies Latest reply on Aug 18, 2003 12:57 AM by Jon Barnett

    Unable to install AXIS?

    David P. Newbie

      I have been attempting to install AXIS 1.1 under JBoss 4.0 DR2 or JBoss 3.2.0 - but cannot get it to deploy or work. I have JSDK 1.4.1_02 installed under Windows XP Pro.

      Per the AXIS install instructions, I created a new folder named "axis" under my <JBoss-root>\server\default\deploy directory, and then copied all the files from the AXIS 1.1 "webapps\axis" sub-directory to it.

      The first time I notice the word "axis" in the JBoss console is when it posts a "Incomplete deployment listing: packages waiting for a deployer" error message. When I try to go to the URL to test AXIS (http://127.0.0.1:8080/axis) as expected (from the JBoss deply errors) I get an "HTTP Status 500 - No Context configured to process this request" error.

      My JBoss 3.2 install uses Jetty, and my JBoss 4.0 install uses Tomcat. Both environments yeild the same type of errors during deployment. (and, no I don't run them both at once).

      I saw an article posted a while ago, that suggested re-naming the JBoss "axis" directory to "axis.war". I tried this, but still got the same results. I tried setting up an AXISCLASSPATH, but still saw the same errors.

      Any ideas why AXIS 1.1 won't work in my environments? I don't know what to try next, to get it to work...

      Thanks for any assistance!
      Dave

        • 1. Re: Unable to install AXIS?
          Jon Barnett Master

          First, it does need to be called axis.war so that JBoss knows to deploy this as a web application.

          Second, try this in 3.2.0 and do it from a clean boot. Just see if you get any problems and if so, report the exact problem (the error stacktrace would be good). I've got Axis 1.1 RC1 running in 3.2.0 so I know with proper configuration it works. I'm just going to try with the Axis 1.1 release.

          Some people have reported some problems with redeployment in 4.0 so stay away from that until you get it working on a production release JBoss.

          I'll check back when I get Axis 1.1 running.

          • 2. Re: Unable to install AXIS?
            Jon Barnett Master

            To confirm: Axis 1.1 deploys on JBoss 3.2.0.

            The directory of importance in the Axis 1.1 distribution is webapps/axis. This is the directory to deploy. Copy it to your JBoss deploy directory. Rename it axis.war.

            I've changed some of the location of files, reflecting the earlier RC organisation.

            saaj.jar and jaxrpc.jar were moved from the axis.war/WEB-INF/lib to the jbossweb-jetty.sar directory. log4j-1.2.8.jar is ditched in my case as there are existing log4j variants floating around in JBoss. I might regret that later if there are incompatibilities. The rest of the axis.war/WEB-INF/lib directory is ok.

            The axis.war/WEB-INF/classes directory is ok if you want the samples. Otherwise you can ditch the samples. If you do, you'll probably want to ditch *.jws files in axis.war.

            Other than that the deployment should be complete. Check the happyaxis page and validate the configuration.

            I can't vouch for the Axis web service deployment service - usually, I modify the server-config.wsdd if necessary. It avoids any security concerns with publishing of web services.

            • 3. Re: Unable to install AXIS?
              David P. Newbie

              Jonlee - As usual, you've fixed the problem! Copying the jar files from the axis.war/WEB-INF/lib directory to the jbossweb-jetty.sar directory allowed it to deploy successfully, under both JBoss 3.2 and 4.0DR2!

              Viewing a list of web services (from the axis index page) under JBoss 4.0 doesn't work, but works fine under 3.2 - so it is probably just something going on with the 4.0 configuration. This is the first thing I have run into (so far) that didn't work the same under 3.2 and 4.0...

              Thanks so much for all your help!
              Dave

              • 4. Re: Unable to install AXIS?
                dmalenic Newbie

                Copy Axis 1.1 jars and uddi4j.jar (if you want to use UDDI) to $JBOSS_HOME\server\<your configuration>\lib directory.
                Make sure that you delete jboss-net.sar from your configuration.
                It works at least with jboss-3.2.1.

                • 5. Re: Unable to install AXIS?
                  crosscourt Newbie

                  can you use the axis in jboss-net.sar?
                  and how?

                  if you can, then why install your own axis?

                  • 6. Re: Unable to install AXIS?
                    Jon Barnett Master

                    You can use the JBoss.NET service. The deployment is different in that you use a WSR, much in the same way as a WAR or an EAR. It is problematic though if you need to support a web service across different web application server platforms as not all of them support a WSR deployment. So for portability/repeatability, you may want to retain the vanilla Axis implementation. YMMV.

                    You can find a tutorial here for JBoss.NET - http://www.csd.abdn.ac.uk/~bscharla/teaching/mtp_software/jboss/jboss-net-EJB-example.shtml.