1 Reply Latest reply on Nov 9, 2003 6:25 AM by Jon Barnett

    WEBSERVICES - Servlet error

    jboss_maniac Newbie

      Hi,
      Got the following error when I try to access my Servlet:(all my log is ok exept when I reach my servlet)

      2003-11-09 12:50:18,921 INFO [STDOUT] Entering Login - processRequest() == LATEST
      2003-11-09 12:50:18,921 WARN [org.jboss.jbossweb] WARNING: Error for /MyWebApp/myServlet
      java.lang.NoClassDefFoundError: org/apache/axis/client/Service
      at au.com.tusc.WebService.Login.callWebService(Login.java:67)
      at au.com.tusc.WebService.Login.processRequest(Login.java:49)
      at au.com.tusc.WebService.Login.doGet(Login.java:32)
      at javax.servlet.http.HttpServlet.service(HttpServlet.java:740)
      at javax.servlet.http.HttpServlet.service(HttpServlet.java:853)
      at org.mortbay.jetty.servlet.ServletHolder.handle(ServletHolder.java:360)
      at org.mortbay.jetty.servlet.WebApplicationHandler.dispatch(WebApplicationHandler.java:294)
      at org.mortbay.jetty.servlet.ServletHandler.handle(ServletHandler.java:558)
      at org.mortbay.http.HttpContext.handle(HttpContext.java:1714)
      at org.mortbay.jetty.servlet.WebApplicationContext.handle(WebApplicationContext.java:507)
      at org.mortbay.http.HttpContext.handle(HttpContext.java:1664)
      at org.mortbay.http.HttpServer.service(HttpServer.java:863)
      at org.jboss.jetty.Jetty.service(Jetty.java:460)
      at org.mortbay.http.HttpConnection.service(HttpConnection.java:775)
      at org.mortbay.http.HttpConnection.handleNext(HttpConnection.java:939)
      at org.mortbay.http.HttpConnection.handle(HttpConnection.java:792)
      at org.mortbay.http.SocketListener.handleConnection(SocketListener.java:201)
      at org.mortbay.util.ThreadedServer.handle(ThreadedServer.java:289)
      at org.mortbay.util.ThreadPool$PoolThread.run(ThreadPool.java:455)

      I do that with eclipse, and when I write my servlet, completiion is Ok, and it compile...

      I don't understand....

      Thanks for your help...

      Alex

        • 1. Re: WEBSERVICES - Servlet error
          Jon Barnett Master

          Your servlet can't locate the axis.jar probably. Either you have not put that in your WEB-INF/lib for your WAR or it is not generally available to the container in which you are running the servlet. You'd need to provide more information on how you have installed Axis before anyone can help you further, if you can't work things out further from here.

          Hope it helps.