1 Reply Latest reply on May 23, 2006 1:37 AM by Thomas Diesler

    JBOSS clustering problems

    Alvaro Escobar Newbie

      I was getting clustering exceptions so i modified the following file:

      server\default\deploy\jbossweb-tomcat55.sar\META-INF\jboss-service.xml

      and uncommented this part:

      jboss.cache:service=TomcatClusteringCache

      and now i am getting the following error:

      14:41:14,606 ERROR [URLDeploymentScanner] Incomplete Deployment listing:

      --- Packages waiting for a deployer ---
      org.jboss.deployment.DeploymentInfo@a273348f { url=file:/C:/jboss/jboss-4.0.4.GA
      /server/default/deploy/jbossweb-tomcat55.sar/ROOT.war/ }
      deployer: null
      status: Starting
      state: INIT_WAITING_DEPLOYER
      watch: file:/C:/jboss/jboss-4.0.4.GA/server/default/deploy/jbossweb-tomcat55.s
      ar/ROOT.war/
      altDD: null
      lastDeployed: 1148323270881
      lastModified: 1147904184733
      mbeans:

      org.jboss.deployment.DeploymentInfo@5b6b6c8 { url=file:/C:/jboss/jboss-4.0.4.GA/
      server/default/deploy/jbossws.sar/jbossws.war }
      deployer: null
      status: Starting
      state: INIT_WAITING_DEPLOYER
      watch: file:/C:/jboss/jboss-4.0.4.GA/server/default/deploy/jbossws.sar/jbossws
      .war
      altDD: null
      lastDeployed: 1148323270881
      lastModified: 1148323267396
      mbeans:

      org.jboss.deployment.DeploymentInfo@c194db6b { url=file:/C:/jboss/jboss-4.0.4.GA
      /server/default/deploy/jmx-console.war/ }
      deployer: null
      status: null
      state: INIT_WAITING_DEPLOYER
      watch: file:/C:/jboss/jboss-4.0.4.GA/server/default/deploy/jmx-console.war/
      altDD: null
      lastDeployed: 1148323273925
      lastModified: 1147904183130
      mbeans:

      org.jboss.deployment.DeploymentInfo@1dd8747f { url=file:/C:/jboss/jboss-4.0.4.GA
      /server/default/tmp/deploy/tmp32517FiboApp.ear-contents/FiboWeb.war }
      deployer: null
      status: Starting
      state: START_SUBDEPLOYMENTS
      watch: file:/C:/jboss/jboss-4.0.4.GA/server/default/tmp/deploy/tmp32517FiboApp
      .ear-contents/FiboWeb.war
      altDD: null
      lastDeployed: 1148323274065
      lastModified: 1148323273975
      mbeans:

      --- Incompletely deployed packages ---
      org.jboss.deployment.DeploymentInfo@c194db6b { url=file:/C:/jboss/jboss-4.0.4.GA
      /server/default/deploy/jmx-console.war/ }
      deployer: null
      status: null
      state: INIT_WAITING_DEPLOYER
      watch: file:/C:/jboss/jboss-4.0.4.GA/server/default/deploy/jmx-console.war/
      altDD: null
      lastDeployed: 1148323273925
      lastModified: 1147904183130
      mbeans:

      --- MBeans waiting for other MBeans ---
      ObjectName: jboss.web:service=WebServer
      State: CONFIGURED
      I Depend On:
      jboss.security:service=JaasSecurityManager
      jboss.cache:service=TomcatClusteringCache
      jboss:service=TransactionManager
      Depends On Me:
      jboss.ws:service=WebServiceDeployerJSE

      ObjectName: jboss.ws:service=WebServiceDeployerJSE
      State: CONFIGURED
      I Depend On:
      jboss.web:service=WebServer
      Depends On Me:
      jboss.ws:service=WebServiceDeployerNestedJSE

      ObjectName: jboss.ws:service=WebServiceDeployerNestedJSE
      State: CONFIGURED
      I Depend On:
      jboss.system:service=MainDeployer
      jboss.ws:service=WebServiceDeployerJSE

      --- MBEANS THAT ARE THE ROOT CAUSE OF THE PROBLEM ---
      ObjectName: jboss.cache:service=TomcatClusteringCache
      State: NOTYETINSTALLED
      Depends On Me:
      jboss.web:service=WebServer


      14:41:14,736 INFO [Server] JBoss (MX MicroKernel) [4.0.4.GA (build: CVSTag=JBos
      s_4_0_4_GA date=200605151000)] Started in 14s:601ms

      http://localhost:8080 does not work.

      Any suggestions?