0 Replies Latest reply on Aug 4, 2006 10:53 AM by Chongyan Ren

    java.rmi.MarshalException: (1)Missing end tag for Body or En

    Chongyan Ren Newbie

      I am really desperate for some experties...not sure if it's inapropriate post it here though.
      hi all,

      I deployed the Calculator web service example (EJB3 endpoint jsr181) in the JBOSS4.04GA server and tried to invoke the service from both j2me&j2se client. the j2se client works fine, but when I used the j2me client, the client threw the folling exception:
      Code:
      java.rmi.MarshalException: (1)Missing end tag for Body or Envelope


      by monitoring the network I got the request and response packages:

      the request:

      <?xml version="1.0" encoding="utf-8"?>.
      <soap:Envelope xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"..xmlns:xsd="http://www.w3.org/2001/XMLSchema"..xmlns
      :soap="http://schemas.xmlsoap.org/soap/envelope/"..xmlns:tns="http://server.reg.src/jaws">.
      <soap:Body>.
      <tns:add>.
      <tns:int_1>4</tns:int_1>.
      <tns:int_2>6</tns:int_2>.
      </tns:add>.
      </soap:Body>.
      </soap:Envelope>.


      this is bizzar coz there are extra "." in every line. but it seems the server can un marshal it correctly as the following response was sent back:

      response:

      <env:Envelope xmlns:env='http://schemas.xmlsoap.org/soap/envelope/'>
      <env:Header/>
      <env:Body>
      <ns1:addResponse xmlns:ns1='http://server.reg.src/jaws' xmlns:xsi='http://www.w3.org/2001/XMLSchema-i
      nstance'>
      <ns1:result>10</ns1:result>
      </ns1:addResponse>
      </env:Body>
      </env:Envelope>

      I believe the problem is the client can't unmarshal the response package correctly. don't know why this happened as the response package is well organised soap message.

      also, I set the client side http version at 1.0 as if I set it to 1.1 the response package would be chunked. (the server side is still 1.1)

      any one has any idea?

      big thanks....