0 Replies Latest reply on May 22, 2002 9:04 PM by HunterHillegas

    Datasources Not Working in RC3

    HunterHillegas Newbie

      I updated to RC3 and I got my datasources to deploy without any exceptions. An EAR that uses one of the datasources is able to lookup the datasource via JNDI but not actually use it... I get this exception later in deployment:

      18:00:30,581 ERROR [EntityContainer] Initialization failed
      org.jboss.deployment.DeploymentException: Error while fixing table name; - nested throwable: (java.sql.SQLException: ResourceException javax.resource.ResourceException: Could not create connection)
      at org.jboss.ejb.plugins.cmp.jdbc.SQLUtil.fixTableName(SQLUtil.java:67)
      at org.jboss.ejb.plugins.cmp.jdbc.bridge.JDBCEntityBridge.(JDBCEntityBridge.java:103)
      at org.jboss.ejb.plugins.cmp.jdbc.JDBCStoreManager.create(JDBCStoreManager.java:333)
      at org.jboss.ejb.plugins.CMPPersistenceManager.create(CMPPersistenceManager.java:155)
      at org.jboss.ejb.EntityContainer.createService(EntityContainer.java:318)
      at org.jboss.system.ServiceMBeanSupport.create(ServiceMBeanSupport.java:170)
      at org.jboss.ejb.Container.invoke(Container.java:778)
      at org.jboss.ejb.EntityContainer.invoke(EntityContainer.java:1024)
      at org.jboss.mx.server.MBeanServerImpl.invoke(MBeanServerImpl.java:549)
      at org.jboss.system.ServiceController$ServiceProxy.invoke(ServiceController.java:867)
      at $Proxy0.create(Unknown Source)

      Here are the log entries from the datasource deployment:

      18:00:15,722 INFO [LocalTxConnectionManager] Starting
      18:00:15,727 INFO [JaasSecurityManagerService] Created securityMgr=org.jboss.security.plugins.JaasSecurityManager@742ec1
      18:00:15,731 INFO [JaasSecurityManagerService] setCachePolicy, c=org.jboss.util.TimedCachePolicy@29c13f
      18:00:15,734 INFO [JaasSecurityManagerService] Added MyRecordsRealm, org.jboss.security.plugins.SecurityDomainContext@4e3b8c to map
      18:00:16,001 INFO [MyRecords] Bound connection factory for resource adapter 'JBoss LocalTransaction JDBC Wrapper' to JNDI name 'java:/MyRecords'
      18:00:16,004 INFO [LocalTxConnectionManager] Started

      BUT... I have debug enabled on my database and I don't see any of the normal chatter when JBoss connects.

      Can anyone help me track this down?

      Thanks,
      Hunter