3 Replies Latest reply on Mar 22, 2004 10:47 AM by soriaedu

    problem with a JCA connection

    soriaedu Newbie

      Hello,
      I have installed jboss-3.0.4.

      I am trying to develop a JCA connection under JBoss.

      I have this -ds.xml file in deploy directory:

      ******************* mprm-ds.xml **************************
      <connection-factories>

      <tx-connection-factory>

      <jndi-name>mPRMResAdapter</jndi-name>

      <adapter-display-name>mPRM resource adapter</adapter-display-name>

      <max-pool-size>64</max-pool-size>

      </tx-connection-factory>

      </connection-factories>

      *************************************************

      In the same deploy directory, I have the folder mprmra.rar. This folder contains several jar files and another folder called META-INF with a ra.xml inside of it. This ra.xml file looks like this:


      ********************** ra.xml **********************

      <?xml version="1.0" encoding="UTF-8"?>
      <!DOCTYPE connector PUBLIC "-//Sun Microsystems, Inc.//DTD Connector 1.0//EN" "http://java.sun.com/dtd/connector_1_0.dtd">


      <display-name>mPRM resource adapter</display-name>
      Resource adapeter for mPRM
      <vendor-name>ProSyst</vendor-name>
      <spec-version>1.0</spec-version>
      <eis-type>mPRM</eis-type>
      1.0

      No License Required
      <license-required>false</license-required>


      <managedconnectionfactory-class>com.prosyst.mprm.adapter.impl.jca.ManagedConnectionFactoryImpl</managedconnectionfactory-class>
      <connectionfactory-interface>com.prosyst.mprm.adapter.jca.ConnectionFactory</connectionfactory-interface>
      <connectionfactory-impl-class>com.prosyst.mprm.adapter.impl.jca.ConnectionFactoryImpl</connectionfactory-impl-class>
      <connection-interface>com.prosyst.mprm.adapter.jca.Connection</connection-interface>
      <connection-impl-class>com.prosyst.mprm.adapter.impl.jca.ConnectionImpl</connection-impl-class>
      <transaction-support>NoTransaction</transaction-support>
      <config-property id="J2EEResourceProperty_1">
      mPRM server uri
      <config-property-name>URI</config-property-name>
      <config-property-type>java.lang.String</config-property-type>
      <config-property-value>socket://192.168.131.41:11449</config-property-value>
      </config-property>
      <config-property id="J2EEResourceProperty_2">
      Default user name
      <config-property-name>UserName</config-property-name>
      <config-property-type>java.lang.String</config-property-type>
      <config-property-value>system</config-property-value>
      </config-property>
      <config-property id="J2EEResourceProperty_3">
      Default user password
      <config-property-name>Password</config-property-name>
      <config-property-type>java.lang.String</config-property-type>
      <config-property-value>system</config-property-value>
      </config-property>
      <authentication-mechanism>
      BasicPassword authentication
      <authentication-mechanism-type>BasicPassword</authentication-mechanism-type>
      <credential-interface>javax.resource.spi.security.PasswordCredential</credential-interface>
      </authentication-mechanism>
      <reauthentication-support>false</reauthentication-support>



      *************************************************

      In the jboss log I get the following error:

      *************************************************
      14:11:02,004 INFO [MainDeployer] Starting deployment of package: file:/opt/HP/jboss/server/default/deploy/mprm-ds.xml
      14:11:02,011 INFO [MainDeployer] deployment waiting for deployer: file:/opt/HP/jboss/server/default/deploy/mprm-ds.xml
      14:11:02,011 INFO [MainDeployer] Deployment of package: file:/opt/HP/jboss/server/default/deploy/mprm-ds.xml is waiting for an appropriate deployer.
      14:11:02,015 ERROR [URLDeploymentScanner] MBeanException: Exception in MBean operation 'checkIncompleteDeployments()'
      Cause: Incomplete Deployment listing:
      Packages waiting for a deployer:
      [org.jboss.deployment.DeploymentInfo@601f0880 { url=file:/opt/HP/jboss/server/default/deploy/mprm-ds.xml }
      deployer: null
      status: null
      state: INIT_WAITING_DEPLOYER
      watch: file:/opt/HP/jboss/server/default/deploy/mprm-ds.xml
      lastDeployed: 1079615462011
      lastModified: 1079615462000
      mbeans:
      ]Incompletely deployed packages:
      [org.jboss.deployment.DeploymentInfo@601f0880 { url=file:/opt/HP/jboss/server/default/deploy/mprm-ds.xml }
      deployer: null
      status: null
      state: INIT_WAITING_DEPLOYER
      watch: file:/opt/HP/jboss/server/default/deploy/mprm-ds.xml
      lastDeployed: 1079615462011
      lastModified: 1079615462000
      mbeans:
      ]MBeans waiting for classes:

      MBeans waiting for other MBeans:

      *************************************************

      So I can´t use the jndi reference java:/mPRMResAdapter. I don´t know where could be the mistake.

      Please, can anybody help me?

      Thank you in advance. Eduardo