1 Reply Latest reply on Feb 4, 2005 9:35 PM by Adrian Brock

    getting warnings when using SecurityIdentityModule: Destroyi

    Dayasakti Kartika Newbie

      Hi,

      I'm running firebird 1.5 and Jboss-3.2.5 under Linux Kernel 2.6.

      My database config is

      <tx-connection-factory>

      <jndi-name>mydataDS</jndi-name>

      <xa-transaction/>
      <track-connection-by-tx/>
      <adapter-display-name>Firebird Database Connector</adapter-display-name>

      <config-property name="Database" type="java.lang.String">localhost/3050:/database/mydata.fdb</config-property>

      <config-property name="TransactionIsolationName">TRANSACTION_REPEATABLE_READ</config-property>

      <min-pool-size>0</min-pool-size>
      <check-valid-connection-sql>SELECT CAST(1 as INTEGER) FROM rdb$database </check-valid-connection-sql>


      <security-domain>mydataDSLogin</security-domain>
      </tx-connection-factory>


      A portion of the login-config.xml is
      <application-policy name = "mydataDSLogin">
      <authentication>
      <login-module code = "org.jboss.resource.security.SecureIdentityLoginModule"
      flag = "required">
      <module-option name = "principal">sysdba</module-option>
      <module-option name = "username">sysdba</module-option>
      <module-option name = "password">**someHexNumbers**</module-option>
      <module-option name = "managedConnectionFactoryName">jboss.jca:service=TxCM,name=mydataDS</module-option>
      </login-module>
      </authentication>
      </application-policy>



      And after examining the logs, I found these kind of warnings

      16:36:58,349 WARN [JBossManagedConnectionPool] Destroying connection that could not be successfully matched: org.jboss.resource.connectionmanager.TxConnectionManager$TxConnectionEventListener@766cda[state=NORMAL mc=org.firebirdsql.jca.FBManagedConnection@1ccaa01 handles=0 lastUse=1107419818348 permit=false trackByTx=false mcp=org.jboss.resource.connectionmanager.JBossManagedConnectionPool$PoolBySubject@198e5d9 context=org.jboss.resource.connectionmanager.InternalManagedConnectionPool@19b9c35]


      Is there something wrong with my configuration ?

      Thanks in advance,
      Julie