1 Reply Latest reply on May 9, 2005 4:53 PM by Marc Batchelor

    JBoss 4.0.1 and Firebird Issue (Yes, I RTF/RTM/RTW)

    Marc Batchelor Newbie

      Hey all,

      I've RTM, I've searched the forums and been directed into FAQs and WIKI's, but I'm still having the NOTYETDEPLOYED problem.

      I turned on debugging, and in the server.log, I find:

      2005-05-06 12:08:18,348 DEBUG [org.jboss.deployment.MainDeployer] Starting deployment of package: file:/E:/jboss-4.0.1sp1/server/default/deploy/firebird-ds.xml
      

      ...
      2005-05-06 12:08:18,609 DEBUG [org.jboss.system.ServiceController] Creating dependent components for: jboss.jca:name=DefaultDS,service=ManagedConnectionFactory dependents are: [ObjectName: jboss.jca:name=DefaultDS,service=ManagedConnectionPool
       state: CONFIGURED
       I Depend On: jboss.jca:name=DefaultDS,service=ManagedConnectionFactory
      
       Depends On Me: jboss.jca:name=DefaultDS,service=TxCM
      ]
      

      ...
      2005-05-06 12:08:18,609 DEBUG [org.jboss.system.ServiceController] Creating dependent components for: jboss.jca:name=DefaultDS,service=ManagedConnectionPool dependents are: [ObjectName: jboss.jca:name=DefaultDS,service=TxCM
       state: CONFIGURED
       I Depend On: jboss.jca:name=DefaultDS,service=ManagedConnectionPool
       jboss.jca:service=CachedConnectionManager
       jboss:service=TransactionManager
      
       Depends On Me: jboss.jca:name=DefaultDS,service=ConnectionFactoryBinding
      ]
      

      ...
      2005-05-06 12:08:18,609 DEBUG [org.jboss.system.ServiceController] Creating dependent components for: jboss.jca:name=DefaultDS,service=TxCM dependents are: [ObjectName: jboss.jca:name=DefaultDS,service=ConnectionFactoryBinding
       state: CONFIGURED
       I Depend On: jboss.jca:name=DefaultDS,service=TxCM
      
       Depends On Me: ]
      

      ...
      down to:
      2005-05-06 12:08:18,869 DEBUG [org.jboss.deployment.MainDeployer] End deployment start on package: firebird-ds.xml
      2005-05-06 12:08:18,869 DEBUG [org.jboss.deployment.MainDeployer] Deployed package: file:/E:/jboss-4.0.1sp1/server/default/deploy/firebird-ds.xml
      


      But in my console, it says this:

      MBEANS THAT ARE THE ROOT CAUSE OF THE PROBLEM:
      ObjectName: jboss.jca:name=DefaultDS,service=DataSourceBinding
       state: NOTYETINSTALLED
       I Depend On:
       Depends On Me: jboss.ejb:persistencePolicy=database,service=EJBTimerService
       jboss:service=KeyGeneratorFactory,type=HiLo
       jboss.mq:service=StateManager
       jboss.mq:service=PersistenceManager
      


      From the server log, it appears that the DefaultDS source is being started, and everything says configured, but I still have the problem.

      As for what I've done (aside from reading all the articles I could find on this):

      a- Copied the example firebird-ds.xml from the examples directory into my default deploy directory. Changed it to reflect the datasource name DefaultDS and my database settings.

      b- Copied the firebirdsql.rar into my default deploy directory.

      c- Removed the hsql* xml documents in jms, and created firebird versions of them.

      d- Tried with and without copying the firebirdsql.jar files to the default/lib directory - no difference between them.

      As far as I can tell, I haven't missed anything... Can someone lend me a hand?

      Thanks,

      Marc

        • 1. Re: JBoss 4.0.1 and Firebird Issue (Yes, I RTF/RTM/RTW)
          Marc Batchelor Newbie

          Ok - I found my problem - it's probably a newbie mistake, but I haven't found it in any of the examples, and maybe it'll help someone else that runs into this.

          My problem was in my ejb-deployer.xml, firebird-jdbc2-service.xml and firebird-jdbc-state-service.xml. In each of these files, I had a line that looks like this:

           <depends optional-attribute-name="DataSource">jboss.jca:service=DatasourceBinding,name=DefaultDS</depends>
          


          Since the Firebird connection is JCA and doesn't use the tag in the *-ds.xml file, then a DatasourceBinding doesn't get created. Instead, this line needs to look like this:

           <depends optional-attribute-name="DataSource">jboss.jca:service=ConnectionFactoryBinding,name=DefaultDS</depends>
          


          Now, my JMS tables are being created. I hope this helps someone else that runs into this problem,

          Marc