0 Replies Latest reply on Feb 28, 2006 2:08 PM by Srinivasan Sangameswara

    Deploying JCA connector on a JBoss cluster

    Srinivasan Sangameswara Newbie

      I have a JCA connector which I am trying to deploy on a JBoss cluster. The connector is packaged as an EAR file. The EAR file deploys (including the JCA connector) with the JBoss 'default' server. The same file when deployed with the JBoss 'all' server throws the following exception. Surprisingly, if I separate out the JCA connector from the EAR file and let JBoss start before putting in the RAR file, the connector deploys correctly.

      The error I get is the following when both the JCA connector and the EAR file are present during JBoss startup.

      10:15:54,777 ERROR [URLDeploymentScanner] Incomplete Deployment listing:

      --- MBeans waiting for other MBeans ---
      ObjectName: jboss.jca:name=LuceneConnector,service=NoTxCM
      State: CONFIGURED
      I Depend On:
      jboss.jca:name=LuceneConnector,service=ManagedConnectionPool
      jboss.jca:service=CachedConnectionManager
      Depends On Me:
      jboss.jca:name=LuceneConnector,service=ConnectionFactoryBinding

      ObjectName: jboss.jca:name=LuceneConnector,service=ManagedConnectionPool
      State: CONFIGURED
      I Depend On:
      jboss.jca:name=LuceneConnector,service=ManagedConnectionFactory
      Depends On Me:
      jboss.jca:name=LuceneConnector,service=NoTxCM

      ObjectName: jboss.jca:name=LuceneConnector,service=ManagedConnectionFactory
      State: CONFIGURED
      I Depend On:
      jboss.jca:name='RapidServer.ear#Lucene-Connector.rar',service=RARDeployment
      Depends On Me:
      jboss.jca:name=LuceneConnector,service=ManagedConnectionPool

      ObjectName: jboss.jca:name=LuceneConnector,service=ConnectionFactoryBinding
      State: CONFIGURED
      I Depend On:
      jboss.jca:name=LuceneConnector,service=NoTxCM

      --- MBEANS THAT ARE THE ROOT CAUSE OF THE PROBLEM ---
      ObjectName: jboss.jca:name='RapidServer.ear#Lucene-Connector.rar',service=RARDep
      loyment
      State: NOTYETINSTALLED
      Depends On Me:
      jboss.jca:name=LuceneConnector,service=ManagedConnectionFactory

      Any help is resolving this will be appreciated.
      Thanks