5 Replies Latest reply on Aug 19, 2006 4:27 PM by Divesh Goyal

    RAR - NOTYETINSTALLED error in JBOSS 4.0.4

    Subbu Samprathi Newbie

      Hi,
      We have written a JCA adapter for Websphere MQ -
      when I tried to deploy the RAR file ( jmsinvoker.jar ) jboss startsup fine.

      But when I deploy the resource file - jboss-mq-ds.xml, I get the following error

      Please help..

      Error
      --- MBEANS THAT ARE THE ROOT CAUSE OF THE PROBLEM ---
      ObjectName: jboss.jca:name='jmsinvoker.rar',service=RARDeployment
      State: NOTYETINSTALLED
      Depends On Me:
      jboss.jca:name=jca/sample,service=ManagedConnectionFactory


      jboss-mq-ds.xml

      <connection-factories>
      <no-tx-connection-factory>
      <jndi-name>jca/sample</jndi-name>
      <rar-name>jmsinvoker.rar</rar-name>
      <connection-definition>
      javax.resource.cci.ConnectionFactory
      </connection-definition>
      <config-property name="queueConnectionFactoryName"
      type="java.lang.String">jms/CCCQF</config-property>

      <config-property name="requestQueueName"
      type="java.lang.String">
      jms/request
      </config-property>

      <config-property name="responseQueueName" type="java.lang.String">
      jms/response
      </config-property>

      <config-property name="defaultExecutionTimeout" type="java.lang.Long">
      60000
      </config-property>

      <config-property name="matchResponseMessageId" type="java.lang.Boolean">
      false
      </config-property>

      </no-tx-connection-factory>
      </connection-factories>


        • 1. Re: RAR - NOTYETINSTALLED error in JBOSS 4.0.4
          Chirag Patel Newbie

          What's the exception that prevented it from installing?

          • 2. Re: RAR - NOTYETINSTALLED error in JBOSS 4.0.4
            Weston M. Price Master

             


            when I tried to deploy the RAR file (jmsinvoker.jar)


            Is this the actual name, jmsinvoker.jar? It should be jmsinvoker.rar.

            Otherwise, JBoss will not deploy this as a RAR file.





            • 3. Re: RAR - NOTYETINSTALLED error in JBOSS 4.0.4
              Subbu Samprathi Newbie

              Sorry, yes it is deployed as jmsinvoker.rar and the and when I create a service - jms-mq-ds.xml I get the following exception:

              - MBeans waiting for other MBeans ---
              ObjectName: jboss.jca:name=jca/sample,service=NoTxCM
              State: CONFIGURED
              I Depend On:
              jboss.jca:name=jca/sample,service=ManagedConnectionPool
              jboss.jca:service=CachedConnectionManager
              Depends On Me:
              jboss.jca:name=jca/sample,service=ConnectionFactoryBinding

              ObjectName: jboss.jca:name=jca/sample,service=ManagedConnectionPool
              State: CONFIGURED
              I Depend On:
              jboss.jca:name=jca/sample,service=ManagedConnectionFactory
              Depends On Me:
              jboss.jca:name=jca/sample,service=NoTxCM

              ObjectName: jboss.jca:name=jca/sample,service=ManagedConnectionFactory
              State: CONFIGURED
              I Depend On:
              jboss.jca:name='jmsinvoker.rar',service=RARDeployment
              Depends On Me:
              jboss.jca:name=jca/sample,service=ManagedConnectionPool

              ObjectName: jboss.jca:name=jca/sample,service=ConnectionFactoryBinding
              State: CONFIGURED
              I Depend On:
              jboss.jca:name=jca/sample,service=NoTxCM

              --- MBEANS THAT ARE THE ROOT CAUSE OF THE PROBLEM ---
              ObjectName: jboss.jca:name='jmsinvoker.rar',service=RARDeployment
              State: NOTYETINSTALLED
              Depends On Me:
              jboss.jca:name=jca/sample,service=ManagedConnectionFactory



              jms-mq-ds.xml entry is :

              <connection-factories>
              <no-tx-connection-factory>
              <jndi-name>sample</jndi-name>
              <rar-name>jmsinvoker.rar</rar-name>
              <connection-definition>
              javax.resource.cci.ConnectionFactory
              </connection-definition>
              <config-property name="queueConnectionFactoryName"
              type="java.lang.String">jms/CCCQF</config-property>

              <config-property name="requestQueueName"
              type="java.lang.String">
              jms/request
              </config-property>

              <config-property name="responseQueueName" type="java.lang.String">
              jms/response
              </config-property>

              <config-property name="defaultExecutionTimeout" type="java.lang.Long">
              60000
              </config-property>

              <config-property name="matchResponseMessageId" type="java.lang.Boolean">
              false
              </config-property>

              </no-tx-connection-factory>
              </connection-factories>


              My ra.xml file contents are :
              <!DOCTYPE connector PUBLIC '-//Sun Microsystems, Inc.//DTD Connector 1.0//EN' 'http://java.sun.com/dtd/connector_1_0.dtd'>

              <display-name>JMSInvokeResourceAdapter</display-name>
              <vendor-name>Sample</vendor-name>
              <spec-version>1.0</spec-version>
              <eis-type>JMS Service</eis-type>
              1.0

              <managedconnectionfactory-class>com.sample.JMSInvokeManagedConnectionFactory</managedconnectionfactory-class>
              <connectionfactory-interface>javax.resource.cci.ConnectionFactory</connectionfactory-interface>
              <connectionfactory-impl-class>com.sample.JMSInvokeConnectionFactory</connectionfactory-impl-class>
              <connection-interface>javax.resource.cci.Connection</connection-interface>
              <connection-impl-class>com.sample.JMSInvokeConnection</connection-impl-class>
              <transaction-support>NoTransaction</transaction-support>
              <config-property>
              <config-property-name>queueConnectionFactoryName</config-property-name>
              <config-property-type>java.lang.String</config-property-type>
              <config-property-value>jms/QCF</config-property-value>
              </config-property>
              <config-property>
              <config-property-name>requestQueueName</config-property-name>
              <config-property-type>java.lang.String</config-property-type>
              <config-property-value>jms/request</config-property-value>
              </config-property>
              <config-property>
              <config-property-name>responseQueueName</config-property-name>
              <config-property-type>java.lang.String</config-property-type>
              <config-property-value>jms/response</config-property-value>
              </config-property>
              <config-property>
              <config-property-name>defaultExecutionTimeout</config-property-name>
              <config-property-type>java.lang.Long</config-property-type>
              <config-property-value>60000</config-property-value>
              </config-property>
              <config-property>
              <config-property-name>matchResponseMessageId</config-property-name>
              <config-property-type>java.lang.Boolean</config-property-type>
              <config-property-value>false</config-property-value>
              </config-property>

              <reauthentication-support>false</reauthentication-support>


              • 4. Re: RAR - NOTYETINSTALLED error in JBOSS 4.0.4
                Weston M. Price Master

                Ahh...you are attempting to deploy a 1.0 JCA adapter where JBoss 4.0.x supports 1.5. My suggestion would be to create a dummy implementation of ResourceAdapter and change your ra.xml file. For an example, look at our JDBC adapter(s) in the src base.

                • 5. Re: RAR - NOTYETINSTALLED error in JBOSS 4.0.4
                  Divesh Goyal Newbie

                  JBoss 4.x should support JCA 1.0 - Its mandated by the JCA 1.5 spec.
                  I have been able to deploy my JCA 1.0 resource adapter to JBoss 4.0.2, 4.0.3 SP1 and 4.0.4.

                  I see this error myself sometimes when I goof up the -ds.xml or ra.xml file.

                  Try removing all your deployments from the deploy folder while the server is running. Then, shut down the server and wipe clean the tmp folder.
                  Again restart the server and freshly deploy your connector. Oh yeah, keep your fingers crossed.