2 Replies Latest reply on Dec 29, 2006 12:53 AM by Rahul Upadhye

    getColumnTypeName returns null

    Rahul Upadhye Newbie

      I have configured a Datasource to use the Oracle Thin driver. After I run the query, I am using the method resultSetMetaData.getColumnTypeName() to get the native DB datatype. But this returns null.

      Is there any way to configure the Datasource so that this datatype is populated?

        • 1. Re: getColumnTypeName returns null
          Vicky Kak Master

          No you don't need to do some additional configuration .
          Can you try executing the same code using the thin driver through the stand-alone java application ? Let me know if that works or not .

          • 2. Re: getColumnTypeName returns null
            Rahul Upadhye Newbie

            I am using the Oracle Thin driver (Oracel 9i client) for configuring the datasource.

            The getColumnType() method of the ResultSetMetadat object returns the JDBC type.
            But the getColumnTypeName() method returns null. This method is being used by the application i am configuring, so the application fails.

            The driver is definitely returning this info. I have tried this by writing a simple JDBC java client. But when i use the JBoss Datasource, this returns null.