1 Reply Latest reply on Feb 4, 2007 10:33 AM by comegree

    i got an error like 'DeploymentException: No Attribute foun

    comegree Newbie

      hi,guys
      Is there anyone can help me?
      I am geting following error when I try to deploy a jca project in jboss 4
      ----------------------------
      DeploymentException: No Attribute found with name: JndiName

      this is the catalogue:
      [img]http://www.ibm.com/developerworks/cn/java/l-jca2/image015.gif[/img]

      thanks

        • 1. Re:  i got an error like 'DeploymentException: No Attribute
          comegree Newbie

          I used jsp to access EJB component,then use EJB to access JCA Resource Adapter, the configure file belows:

          ejb-jar.xml

          <?xml version="1.0"?>
          <!DOCTYPE ejb-jar
          PUBLIC "-//Sun Microsystems, Inc.//DTD Enterprise JavaBeans 2.0//EN"
          "http://java.sun.com/dtd/ejb-jar_2_0.dtd"
          >

          <ejb-jar>
          <enterprise-beans>

          <ejb-name>DemoEJB</ejb-name>
          com.hellking.jca.ejb.DemoHome
          com.hellking.jca.ejb.Demo
          <ejb-class>com.hellking.jca.ejb.DemoEJB</ejb-class>
          <session-type>Stateless</session-type>
          <transaction-type>Container</transaction-type>
          <resource-ref>
          <res-ref-name>eis/DemoEISFactory</res-ref-name>
          <res-type>javax.resource.cci.ConnectionFactory</res-type>
          <res-auth>Container</res-auth>
          </resource-ref>


          </enterprise-beans>
          </ejb-jar>


          jboss.xml

          <?xml version="1.0"?>


          false
          <container-configurations />
          <resource-managers />
          <enterprise-beans>

          <ejb-name>DemoEJB</ejb-name>
          <jndi-name>ejb/demo</jndi-name>
          <resource-ref>
          <res-ref-name>eis/DemoEISFactory</res-ref-name>
          <jndi-name>java:/NoTransDemo</jndi-name>
          </resource-ref>

          </enterprise-beans>


          here is the resource adapter's ra.xml:

          <?xml version="1.0" encoding="UTF-8"?>
          <!DOCTYPE connector PUBLIC '-//Sun Microsystems, Inc.//DTD Connector 1.0//EN' 'http://java.sun.com/dtd/connector_1_0.dtd'>


          <display-name>DemoRA</display-name>
          <vendor-name>HELLKING</vendor-name>
          <spec-version>1.0</spec-version>
          <eis-type>NO TRANS</eis-type>
          1.2

          <managedconnectionfactory-class>com.hellking.jca.DemoManagedConnectionFactory</managedconnectionfactory-class>
          <connectionfactory-interface>javax.resource.cci.ConnectionFactory</connectionfactory-interface>
          <connectionfactory-impl-class>com.hellking.jca.DemoConnectionFactoryImpl</connectionfactory-impl-class>
          <connection-interface>com.hellking.jca.DemoConnection</connection-interface>
          <connection-impl-class>com.hellking.jca.DemoConnectionImpl</connection-impl-class>
          <transaction-support>NoTransaction</transaction-support>
          <config-property>
          <config-property-name>Server</config-property-name>
          <config-property-type>java.lang.String</config-property-type>
          <config-property-value>localhost</config-property-value>
          </config-property>
          <config-property>
          <config-property-name>Port</config-property-name>
          <config-property-type>java.lang.Integer</config-property-type>
          <config-property-value>2008</config-property-value>
          </config-property>
          <reauthentication-support>false</reauthentication-support>



          thanks for any help