1 Reply Latest reply on Jul 24, 2007 11:06 AM by Adrian Brock

    JCA deployment on JBOSS 4.0.0

    kumar reddy Newbie

      Hi All,

      I am trying to deploy JCA for infranet on JBOSS4.0.0. I have kept the files ra.xml and infranet-ds.xml files under META-INF and created rar file and deployed in server/all/deploy folder.

      Following are the two files


      infranet-ds.xml


      <?xml version="1.0" encoding="UTF-8"?>
      <connection-factories>
      <tx-connection-factory>
      <jndi-name>Ombi.Infranet</jndi-name>
      <rar-name>infranetconnector.rar</rar-name>
      <connection-definition>
      javax.resource.cci.ConnectionFactory
      </connection-definition>
      </tx-connection-factory>
      </connection-factories>


      ra.xml


      <?xml version="1.0" encoding="UTF-8"?>
      <connector id="Connector_ID" version="1.5" xmlns="http://java.sun.com/xml/ns/j2ee" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://java.sun.com/xml/ns/j2ee http://java.sun.com/xml/ns/j2ee/connector_1_5.xsd">
      <display-name>InfranetConnector</display-name>
      <vendor-name>Covad</vendor-name>
      <eis-type>Infranet</eis-type>
      <resourceadapter-version>1.0</resourceadapter-version>

      <resourceadapter-class>
      org.jboss.resource.deployment.DummyResourceAdapter
      </resourceadapter-class>
      <outbound-resourceadapter>
      <connection-definition>
      <managedconnectionfactory-class>com.covad.billing.framework.connector.InfLocalTxManagedConnectionFactory</managedconnectionfactory-class>
      <config-property>
      <config-property-name>BrandSwitch</config-property-name>
      <config-property-type>java.lang.String</config-property-type>
      <config-property-value>switch</config-property-value>
      </config-property>
      <connectionfactory-interface>javax.resource.cci.ConnectionFactory</connectionfactory-interface>
      <connectionfactory-impl-class>com.covad.billing.framework.connector.InfConnectionFactory</connectionfactory-impl-class>
      <connection-interface>javax.resource.cci.Connection</connection-interface>
      <connection-impl-class>
      com.covad.billing.framework.connector.InfCciConnection
      </connection-impl-class>
      </connection-definition>
      <transaction-support>LocalTransaction</transaction-support>
      <authentication-mechanism>
      <authentication-mechanism-type>BasicPassword</authentication-mechanism-type>
      <credential-interface>javax.resource.spi.security.PasswordCredential</credential-interface>
      </authentication-mechanism>
      <reauthentication-support>false</reauthentication-support>
      </outbound-resourceadapter>




      Following is the error displayed when i deployed :

      Stack Trace on JBOSS console
      16:35:02,952 INFO [EARDeployer] Init J2EE application: file:/E:/jboss-4.0.0[1]/jboss-4.0.0/server/a
      ll/deploy/omBilling.ear
      16:35:06,999 INFO [EjbModule] Deploying OMBillingInterface
      16:35:07,046 INFO [EJBDeployer] Deployed: file:/E:/jboss-4.0.0[1]/jboss-4.0.0/server/all/tmp/deploy
      /tmp22403omBilling.ear-contents/omBilling.jar
      16:35:07,077 INFO [EARDeployer] Started J2EE application: file:/E:/jboss-4.0.0[1]/jboss-4.0.0/serve
      r/all/deploy/omBilling.ear
      16:35:07,187 ERROR [URLDeploymentScanner] Incomplete Deployment listing:
      MBeans waiting for other MBeans:
      ObjectName: jboss.jca:service=TxCM,name=Ombi.Infranet
      state: CONFIGURED
      I Depend On: jboss.jca:service=ManagedConnectionPool,name=Ombi.Infranet
      jboss.jca:service=CachedConnectionManager
      jboss:service=TransactionManager

      Depends On Me: jboss.jca:service=ConnectionFactoryBinding,name=Ombi.Infranet

      ObjectName: jboss.jca:service=ManagedConnectionPool,name=Ombi.Infranet
      state: CONFIGURED
      I Depend On: jboss.jca:service=ManagedConnectionFactory,name=Ombi.Infranet

      Depends On Me: jboss.jca:service=TxCM,name=Ombi.Infranet

      ObjectName: jboss.jca:service=ManagedConnectionFactory,name=Ombi.Infranet
      state: CONFIGURED
      I Depend On: jboss.jca:service=RARDeployment,name='infranetconnector.rar'

      Depends On Me: jboss.jca:service=ManagedConnectionPool,name=Ombi.Infranet

      ObjectName: jboss.jca:service=ConnectionFactoryBinding,name=Ombi.Infranet
      state: CONFIGURED
      I Depend On: jboss.jca:service=TxCM,name=Ombi.Infranet

      Depends On Me:

      MBEANS THAT ARE THE ROOT CAUSE OF THE PROBLEM:
      ObjectName: jboss.jca:service=RARDeployment,name='infranetconnector.rar'
      state: NOTYETINSTALLED
      I Depend On:
      Depends On Me: jboss.jca:service=ManagedConnectionFactory,name=Ombi.Infranet

      Please guide me if anything needs to be modified in xml files.Please help me this is very urgent your help will be appreciated.

      thanks in advance