1 Reply Latest reply on Jul 25, 2008 8:49 AM by Adrian Brock

    Turning off CachedConnectionManager

    deepak aggarwal Newbie

      Hi,
      I had been getting IllegalStateException when doing Jboss TM suspend and begin, ie, suspend an outer transaction and start a new inner transaction. Exception was:

      [STDERR] java.lang.IllegalStateException: Trying to change transaction TransactionImple < ac, BasicAction: a0359b1:4e3:4734f5c7:fc status: ActionStatus.RUNNING > in enlist!
      
       [STDERR] at org.jboss.resource.connectionmanager.TxConnectionManager$TxConnectionEventListener.enli
      st(TxConnectionManager.java:525)
      
       [STDERR] at org.jboss.resource.connectionmanager.TxConnectionManager.transactionStarted(TxConnectio
      nManager.java:328)
      


      I had posted this question earlier on Jboss Transactions forum but later on I found that this is a JCA issue. Refer to:
      http://www.jboss.com/index.html?module=bb&op=viewtopic&t=137565

      As this is due to "Lazy JCA Enlistment" feature of CachedConnectionManager, can I disable it? If I disable it, can I still do <track-connection-by-tx>? I am willing to pay the cost of losing optimization, provided I don't loose any transaction correctness. If this is something which is already in the documentation out there (checked the jboss jca wiki but couldn't find much), I'll appreciate it if you can point me to it.

      Thanks.

        • 1. Re: Turning off CachedConnectionManager
          Adrian Brock Master

           

          "aggarwald" wrote:

          As this is due to "Lazy JCA Enlistment" feature of CachedConnectionManager,


          Lazy JCA enlistement is not your problem, you're trying to share connections
          across transaction boundaries. Almost certainly not what you want.
          The usual answer to this FAQ is use a no-tx-datasource if you don't want the
          connections enlisting in the transactions.