6 Replies Latest reply on Nov 14, 2008 11:35 AM by J Plater

    Setting up XA datasource with oranxo driver and RAC

    J Plater Newbie

      I am trying to setup a XA datasource that uses the oraxno driver and connects to oracle RAC. I can't seem to figure out what the xml file should look like. I searched around and found http://www.jboss.org/community/docs/DOC-12246 but it doesn't show any examples with the oranxo drivers. Does anyone know how to do this or where I can find more information on how to do it? I have been able to get normal datasource to work with the oranxo driver and connect to RAC but I can't figure out how to do XA datasources. Judging by the oranxo documentation it looks like I should do something like:

       <xa-datasource-property name="User">USERNAME</xa-datasource-property>
       <xa-datasource-property name="Password">PASSWORD</xa-datasource-property>
       <xa-datasource-property name="Host">HOST</xa-datasource-property>
       <xa-datasource-property name="Port">PORT</xa-datasource-property>
       <xa-datasource-property name="Service">SERVICENAME</xa-datasource-property>
       <xa-datasource-property name="Failover">True</xa-datasource-property>
       <xa-datasource-property name="Host1">HOST1</xa-datasource-property>
       <xa-datasource-property name="Port1">PORT1</xa-datasource-property>
       <xa-datasource-property name="Host2">HOST2</xa-datasource-property>
       <xa-datasource-property name="Port2">PORT2</xa-datasource-property>
      


      But it doesn't work - it complains that setHost2() doesn't exist. Anyone have any success setting this up? Thanks.