2 Replies Latest reply on Jul 1, 2009 6:21 AM by Preetam Palwe

    xa-datasource for postgresql is not getting deployed in jbos

    Preetam Palwe Newbie

      hello all

      i want to create xa-datasource for postgresql (windows version 8.3)
      i am using recently downloaded jboss-5.1.0.GA-jdk6
      but somehow the ds is not getting created. there are no errors / exceptions in logs. (even no debug logs about this activity!)

      where it might be going wrong?
      (My other local-tx-datasource is working fine!)

      Thanks in advance for any help!
      ~PP

      here is my configuration of
      jboss-5.1.0.GA-jdk6\server\default\deploy\jboss-ds-xa.xml

      <?xml version="1.0" encoding="UTF-8"?>
      <datasources>
       <xa-datasource>
       <jndi-name>TZ</jndi-name>
      
       <xa-datasource-class>org.postgresql.xa.PGXADataSource</xa-datasource-class>
       <xa-datasource-property name="ServerName">127.0.0.1</xa-datasource-property>
       <xa-datasource-property name="PortNumber">5432</xa-datasource-property>
      
       <xa-datasource-property name="DatabaseName">sz</xa-datasource-property>
       <xa-datasource-property name="User">postgres</xa-datasource-property>
       <xa-datasource-property name="Password">postgres</xa-datasource-property>
      
       <min-pool-size>5</min-pool-size>
       <max-pool-size>20</max-pool-size>
       <blocking-timeout-millis>2000</blocking-timeout-millis>
       <idle-timeout-minutes>5</idle-timeout-minutes>
       <new-connection-sql>;</new-connection-sql>
       <check-valid-connection-sql>;</check-valid-connection-sql>
      
       </xa-datasource>
      
       <xa-datasource>
       <jndi-name>TZ_Archive</jndi-name>
      
       <xa-datasource-class>org.postgresql.xa.PGXADataSource</xa-datasource-class>
       <xa-datasource-property name="ServerName">127.0.0.1</xa-datasource-property>
       <xa-datasource-property name="PortNumber">5432</xa-datasource-property>
      
       <xa-datasource-property name="DatabaseName">sz-archive</xa-datasource-property>
       <xa-datasource-property name="User">postgres</xa-datasource-property>
       <xa-datasource-property name="Password">postgres</xa-datasource-property>
      
       <min-pool-size>5</min-pool-size>
       <max-pool-size>20</max-pool-size>
       <blocking-timeout-millis>2000</blocking-timeout-millis>
       <idle-timeout-minutes>5</idle-timeout-minutes>
       <new-connection-sql>;</new-connection-sql>
       <check-valid-connection-sql>;</check-valid-connection-sql>
      
       </xa-datasource>
      
      </datasources>