3 Replies Latest reply on May 24, 2002 6:22 PM by Dave Patterson

    Petstore 1.1.2  problem

    Anton Newbie

      I have a problem with Petstore deployment.
      I found no any helpful information in forum&doc, so I post this message..

      During Petstore (1.1.2 with jps112-01.zip patch) compilation the
      "no local enterprise.deployment.application.description"
      error was occured few times. However petstore.ear was created.
      Next, I`ve put this .ear into Deploy directory and it was deployed with this message:
      [14:47:22,885,AutoDeployer] DeploymentInfo failed:file:/D:/JBoss/JBoss-2.4.4_Tomcat-4.0.1/jboss/deploy/petstore.ear
      org.jboss.deployment.J2eeDeploymentException: Error in parsing application.xml: External entity not found: "http://java.sun.com/dtd/application_1_3.dtd".
      at org.jboss.deployment.LegacyInstaller.execute(LegacyInstaller.java:199)
      ....
      Then I typed http://localhost:8080/estore in browser and it return "HTTP 500 - Internal server error"
      JBoss Log:
      [14:51:26,285,EmbeddedCatalinaServiceSX] StandardHost[localhost]: MAPPING configuration error for request URI
      [14:51:26,285,EmbeddedCatalinaServiceSX] HttpProcessor[8080][4] process.invoke
      java.lang.NullPointerException
      ..

      Please, give me some advice. What I forgot?

      JBoss-2.4.4_Tomcat-4.0.1
      jdk1.3.1_01
      j2sdkee1.3.1

        • 1. Re: Petstore 1.1.2  problem
          Rich Gardner Newbie

          If you deployment has failed, then there may not be any well formed PetStore application to run. Secondly, the correct URL for accessing the petstore should be http://localhost:<port#>/petstore

          I believe the "p" in petstore was left off inadvertently. Of course, replace <port#> with your appropriate port number for your web server installation.

          T Bone

          • 2. Re: Petstore 1.1.2  problem
            Rich Gardner Newbie

            Anton,

            Please disregard my first reply to this thread. I was writing to the PetStore 1.3.01 implementation. After you get a clean deploy with 1.1.2, try the URL http://localhost:8080/estore/index.html

            • 3. Re: Petstore 1.1.2  problem
              Dave Patterson Newbie

              Hi Anton,

              I have just been through the same process. The application.xml files in the generated ear file have DTD references that point to external entities. If your installaion does not have internet access at deploy time then then these entites will not be visible.

              There are 2 application.xml files. One is at the root of the archive. One is in META-INF. I expanded the ear, removed the DTD lines and re-jar'd the archive. (You could host the DTD files locally if you were keen but it is not necessary in this case.)

              Good luck.

              Dave Patterson.