3 Replies Latest reply on Sep 7, 2007 6:40 AM by Marcelo Krebber

    Trouble rerendering content in a panel after upgrade to RC5

    Kristian Aaslund Newbie

      As mentioned in another topic, I have recently upgraded from RF 3.0.2 and a4j 1.1.2 snapshots to RF 3.1.0 RC5.

      My environment:
      Tomcat 5.5.20
      JDK 1.5.0_12
      Facelets 1.1
      Spring 2.0.6
      Hibernate 3.2.4
      MyFaces 1.1.6 snapshot
      Tomahawk 1.1.7 snapshot
      Acegi security 1.0.4

      I use a modal panel from Yahoo! User Interface Library (YUI) to display dialogs. I open a panel with the following code:

      <a4j:commandLink actionListener="#{backingBean.openFoo}"
       oncomplete="YAHOO.myCompany.editFooPanel.show()"
       reRender="editFoo_body" >
      


      I am rerendering the body of the panel to populate it with the data from the Foo object. The code inside the panel looks like this:

      <ui:composition>
       <t:div id="editFooPanel" styleClass="hidden">
       <div class="hd">
       #{msg.section_header_foo}
       </div>
       <t:div id="editFoo_body" styleClass="bd">
       <h:form>
       // form elements here
       </h:form>
       </t:div>
       </t:div>
      </ui:composition>
      


      With RF 3.0.2 and a4j 1.1.2 this worked perfectly, but after the upgrade the panel is opened and then closed again immediately when i activate the <a4j:commandLink>.

      Can someone tell me why, or suggest a workarround?

        • 1. Re: Trouble rerendering content in a panel after upgrade to
          Marcelo Krebber Newbie

          i believe there are more things that are not working quite yet. just upgraded to rc5 (with latest snapshot same problem) and simpleToglePanel ist not displaying the header right for IE. With firefox this working right. this was working correctly with RC3.

          greetings.

          "kaaslund" wrote:
          As mentioned in another topic, I have recently upgraded from RF 3.0.2 and a4j 1.1.2 snapshots to RF 3.1.0 RC5.

          My environment:
          Tomcat 5.5.20
          JDK 1.5.0_12
          Facelets 1.1
          Spring 2.0.6
          Hibernate 3.2.4
          MyFaces 1.1.6 snapshot
          Tomahawk 1.1.7 snapshot
          Acegi security 1.0.4

          I use a modal panel from Yahoo! User Interface Library (YUI) to display dialogs. I open a panel with the following code:

          <a4j:commandLink actionListener="#{backingBean.openFoo}"
           oncomplete="YAHOO.myCompany.editFooPanel.show()"
           reRender="editFoo_body" >
          


          I am rerendering the body of the panel to populate it with the data from the Foo object. The code inside the panel looks like this:

          <ui:composition>
           <t:div id="editFooPanel" styleClass="hidden">
           <div class="hd">
           #{msg.section_header_foo}
           </div>
           <t:div id="editFoo_body" styleClass="bd">
           <h:form>
           // form elements here
           </h:form>
           </t:div>
           </t:div>
          </ui:composition>
          


          With RF 3.0.2 and a4j 1.1.2 this worked perfectly, but after the upgrade the panel is opened and then closed again immediately when i activate the <a4j:commandLink>.

          Can someone tell me why, or suggest a workarround?


          • 2. Re: Trouble rerendering content in a panel after upgrade to
            Nick Belaevski Master

            Hello!

            Kaaslund, could you please provide demo app to see the problem?

            Marc, could you please provide a screenshot on how simpleTogglePanel is looking in IE?

            You can send it to nbelaevski at exadel dot com. Thank you!

            • 3. Re: Trouble rerendering content in a panel after upgrade to
              Marcelo Krebber Newbie

              hi nick,

              the problem is easy to describe. the panel is just not visible - i believe the background color or smth similar is missing or not being rendered - the object itself is there, but just shown as a "white" area - the functionality of expanding/detracting is also working - but, as is i said, i click on an "empty" area.. strangely, IE gives as error "Richfaces not know.." or smthg similar. IE version 6.0.x

              hope it helps. marcelo

              "nbelaevski" wrote:
              Hello!

              Kaaslund, could you please provide demo app to see the problem?

              Marc, could you please provide a screenshot on how simpleTogglePanel is looking in IE?

              You can send it to nbelaevski at exadel dot com. Thank you!